• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Doom 3...um...help?

Jestermask

WinTMBG Professional
#1
So after I've installed Doom 3 on my machine and try to run it, all I get is the groovy spalsh screen and nothing else. It just stays there. After waiting about 5 minutes to make sure that it wasn't going to start, I tried using other applications, and they ran fine, which to me says that Doom 3 wasn't even attempting to try to run. I've tried re-installation, optimization of my OS, and I have updated drivers for everything.
System specs:
Athlon 2000+
768MB PC2100
GF4 Ti4600
XP Pro

As far as I can tell, my machine easily should be able to handle the game itself, but it simply doesn't wanna run.

Can anyone help?

~JM
 

~bk

I
Political User
#4
This happened to me when I installed Red Alert 2. I was running Windows XP and I had to change the compatibilty mode to Windows ME.

I'm just taking a guess. That might be a problem.
 

Sazar

F@H - Is it in you?
Staff member
Political User
#6
do you have the retail copy first and foremost :cool:

a few warezed versions exhibit the same symptoms...
 

Wrathchild

OSNN Senior Addict
#14
Doom III

I'M running it on a P4 - 3.2GHz canterwood, 2 gigs of PC3200 DDR and a GeForce 5900 Ultra. Runs smmoth as silk on "High" settings, a little choppy on "Ultra" settings. One thing I did notice though; the old Id refresh rate issue is still there. I had to go into my Nvidia control applet to turn on refresh rate override, which made most of the flickering go away.

-RW
 

Jestermask

WinTMBG Professional
#15
*coughs* Um, that's great and all Wrathchild, but I don't suppose there was some glint of helpful advice that I missed in that entry? Some way to help me out?
 

leedogg

Gojyone kawaiiiiiiii!
#19
lol. funny thread.

OK make sure you have the latest directX drivers installed. Next try reverting to a different set of video drivers.

Worst comes to worst and you cant get it working, I might be interested in taking it off ya ;)
 

Wrathchild

OSNN Senior Addict
#20
Jestermask said:
*coughs* Um, that's great and all Wrathchild, but I don't suppose there was some glint of helpful advice that I missed in that entry? Some way to help me out?
OK. I'll explain. I listed my hardware and reported the games' performance on that hardware. This way, you can compare your own to mine to rule out any hardware-specific issues. I also mention in my post that in order to get rid of the "flickering" you need to enable the refresh rate override in your ATI or Nvidia control panel. Although this doesn't speak directly to your issue, I thought it socially correct to include it in my post on the off chance that any users who read the post might benefit from the sharing of the information. Regarding your cough, I recommend Ludens Cherry throat lozenges. They work great and taste great too!

-Wrath
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,012
Latest member
Sierge