Unable to play MPG or AVI video files

0pensource

OSNN Junior Addict
Joined
11 Jan 2004
Messages
20
Recently, I discovered that I am unable to play/view MPG or AVI files with MS Windows Media Player 9.x or PowerDVD. I AM, however, able to play WMV files with MS Media Player.

I also have QuickTime's Player installed that appears to just about anything.

I have checked the filetype associations and they show Windows Media Player as the default: (EX:)

"C:\Program Files\Windows Media Player\wmplayer.exe" /prefetch:8 /Open "%L"

Really perplexed about this. I even reinstalled Windows Media Player with no change.

Any ideas?


Thanks in advance,

-Miles
 

Reg

eXperienced!
Joined
2 Mar 2002
Messages
639
You might be missing codecs. Try downloading a CODEC pack to replace the codecs.
 

0pensource

OSNN Junior Addict
Joined
11 Jan 2004
Messages
20
Reg said:
You might be missing codecs. Try downloading a CODEC pack to replace the codecs.

Got a link.... a little nervous about DL'ing codecs from just about anywhere.


Thanks,

-Miles
 

vern

Dominus
Political Access
Joined
2 Mar 2002
Messages
1,572
Codec packs should solve all your codec problems. They install all the common codecs for you. Nimo codec packs and K-lite codec packs are popular. Both of which you can google.
 

0pensource

OSNN Junior Addict
Joined
11 Jan 2004
Messages
20
o_87 said:
I personally find the K-Lite Codec Pack to be great, you can download it from here: http://doa2.host.sk/codecs/


I did not know that it would be a good idea to get codecs from k-Lite. Cool!


Will DL,

-Miles (thanks)


"It has become almost a cliché to remark that nobody boasts of ignorance of literature, but it is socially acceptable to boast ignorance of science and proudly claim incompetence in mathematics."

-Richard Dawkins
 

0pensource

OSNN Junior Addict
Joined
11 Jan 2004
Messages
20
vern said:
Codec packs should solve all your codec problems. They install all the common codecs for you. Nimo codec packs and K-lite codec packs are popular. Both of which you can google.

Installing all of the codecs (not sure if the option to select is there) can be done without any fear of changing what already works?



-Miles
 

0pensource

OSNN Junior Addict
Joined
11 Jan 2004
Messages
20
o_87 said:
That's very weird. I think there was an update to WMP9 that came out recently, have you tried updating WMP9?

To update, start WMP9, Help > Check For Player Updates

Already checked: updated.


-Miles
 

Grandmaster

Electronica Addict
Political Access
Joined
3 Feb 2002
Messages
10,574
I can't really think of anything else that might solve this. Maybe do a System Restore to a recent checkpoint?
 

0pensource

OSNN Junior Addict
Joined
11 Jan 2004
Messages
20
SPeedY_B said:
Try VideoLAN: http://videolan.org ; see if that will play the files you are having trouble with.


I have VideoLan and run it as my only alternative. I have no problem continuing to use it. Just a little bugged about this "bug".


-Miles
 

Android412

OSNN Addict
Joined
5 Jan 2004
Messages
199
Try going into the options menu, and making sure that you have MPG checked off in the playback file types.
 

LeeJend

OSNN Veteran Addict
Joined
25 Jan 2003
Messages
5,291
Don't know why the MPG aren't playing, but Real and MS are litigating each other right now and I think the AVI hooks have been pulled out of Media Player, possibly on the last update, as part of the dispute. I have to use real to view AVIs. I noticed the problem in the last couple of weeks.
 

Xie

- geek -
Joined
29 Sep 2003
Messages
5,274
you get any errors or just won't play and nothing happens?
 

napalmnthemorning

OSNN Senior Addict
Joined
23 Jun 2002
Messages
721
I hope you get the bug fixed. reinstalling might do the trick. I haven't used Media Player 9 for quite awhile. VideoLAN is excellent, and I mostly use Zoom Player professional. Here is a codec package I use that is excellent. 3ivx D4 4.5

Zoom Player standard edition is free.
Plays every media format (DIVX/XVID/VP3-6/MPEG4/VCD/SVCD/RealVideo/QuickTime/Flash/CDAudio) as long as you have the components installed.
 

Members online

No members online now.

Latest profile posts

Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.
Terrahertz wrote on Electronic Punk's profile.
Yo fellas!
Electronic Punk wrote on Sazar's profile.
Where are you buddy?
Perris Calderon wrote on Electronic Punk's profile.
Hey EP! All good with me, applying for Microsoft MVP right now, should have done this a while ago.

Notifications don't work, I only found your response by coming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier!
Perris Calderon wrote on Electronic Punk's profile.
EP, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there!

Forum statistics

Threads
61,997
Messages
673,410
Members
5,588
Latest member
dera