• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Surround sound in Doom 3

Glass

sgàthan ìnnleachd
#1
I have an Audigy 2 ZS with latest drivers and a 7.1 sound system, and I have 7.1 surround slected in Windows control panel, but when I try to select surround within Doom 3's menu, it says something like 'No surround system detected. Check Windows control panel settings' so I double checked and I definitely have 7.1 surround slected in there. I even tried manually changing the numberofSpeakers line in the DoomConfig.cfg file from 2 to 5, 6, and 7 and making the file read only, but I still can't get positional audio. Any ideas?
 

Electronic Punk

willalwaysbewithyou
Staff member
Political User
#2
Sounds like (forgive the pun) there are a few issues with Doom III's sound at the moment.

Did you get the new ZS drivers from Creative?
(ie less than a week old)
 

Wrathchild

OSNN Senior Addict
#3
Had the same problem, same sound card. When I checked my speaker settings in the Creative speaker settings menu (not the Windows applet) I noticed that 2 speakers was selected for some reason. I switched it to 5.1 speakers, closed it, went into Doom, selected Surround speakers and voila! It worked fine. Hope that helps.

-Wrath
 

apu95

Caffeine-->Code Converter
#4
yeah i had the same thing, but im running on 4.1...for some reason Doom 3 doesnt consider 4.1 as surround, so i had to change the windows control panel to 5.1 (it doesnt have 4.1, i dont know why) and it worked
 

Nismo83

OSNN AZN Addict
#5
Wrathchild said:
Had the same problem, same sound card. When I checked my speaker settings in the Creative speaker settings menu (not the Windows applet) I noticed that 2 speakers was selected for some reason. I switched it to 5.1 speakers, closed it, went into Doom, selected Surround speakers and voila! It worked fine. Hope that helps.

-Wrath
what driver are u using? I'm using the same card as yours and yes... my creative applet is showing 5.1 but getting distorted then cut off sound when i play in surround mode.
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,018
Latest member
dixoncarry