• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Samsung SC125L (52x CDROM) Problems

R

r3n3gad3

Guest
#1
Hey all,
I just got a new CDROM Drive (Samsung SC125L - 52x CDROM). And... lol, u guesed it, it aint working properly :p

I have tried it on 2 PCs and i get exactly the same probs so i was wondering if anybody had any knowlege of misbehaving samsung cdroms :) heres the message i sent to the place i got it:

Hello,
I recently bought a "52x Samsung CD-ROM" from you - which dosent work.
I have tried to install it on both my PCs with no success (one windowsXP and one windowsME), and I was wondering if you could help.

The model number is SC125L (or so the device manager says) - maybe there are some issues with this device (as it doesnt work on either PCs).

Both PCs detect it in BIOS - and windows detects it also. But, when I insert a CD (normal or cd-r etc.), it says "Please inser a disk" - saying that it cant find one right?

I tried going to the samsung website for drivers, but they only provide you with firmware updates (of which i couldn't seem to get working) - so no help there realy.

Windows also says that the device is working, no conflicts and its enabled.

I used a different CDROM drive in both the machines (set up like the new one - master on ide2) and the old CDROM worked...

Thanks in advance - Nick
 
B

boxman

Guest
#2
Interesting I have the same drive with no problems at all. I have it setup on it's own IDE channel. You make sure that you have the Master/Slave relationship set up properly. Also if you are using 80 conductor cables, try 40 conductor cables. My $.02
 
R

r3n3gad3

Guest
#4
Hmm, well i'm pretty sure its not the cable because each of the machines i tryed it on have the two diffrent cables - if ya get me (40 and 80)... lol... i know what i'm talking about.

i'll try cable select and tell ya what happens :) thx guys
 
R

r3n3gad3

Guest
#5
nope, no luck - tried eveything said here and more... hardware at fault here do ya think? because it isnt even spinning the disc up :S

things i tried so far:
  • using 40 conductor cables (instead of 80)
  • disconnecting all other drives on that interface (and making it master)
  • tried it on a p1 (windowsME) and an amd duron (windowsXP) using both points above
  • installing latest firmware from samsung site
  • tried using the CS option (jumper setting)
  • tried a variety of CD media (inluding cd-r and cd-rom)

from this would you reach the conclusion that it is hardware falilure (on the cdrom drive)? or is it just me....
 
D

dejav00

Guest
#8
...

Last thing, bad power maybe?

Try swithching power for the HDD and CD-ROM, see if that works, doesn't sound like that's the problem but....
 
R

r3n3gad3

Guest
#9
nope, ur right, looks like a dud :( ... changing the power didnt work... oh well - thx anyway guys
 

Members online

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,962
Messages
673,247
Members
89,017
Latest member
Seggar