• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Problems with ATI Radeon 9500, 128MG

#1
I just got a new video care, ATI Radeon 9500 Pro, 128 MG and a new Samsung Syncmaster 955DF FlatScreen monitor.

Since the install, I have had the following problems,

When surfing the web IE locks up or the computer boots up,

When Running 3D games I get some weird white graphics in the trees (in the game) and the game will lock up or boot me back to my desk top.

Did not have problems before this installation and I do not think it is the monitor.

1.6 Ghz, P4 Intell
Gigabyte Titan MotherBoard
512 RAM

Any help would be appreciated. thanks
 
#3
New Drivers

The current version driver I have is dated 10-12-2002 and titled version 6.13.10.6200.

Though I noticed that at the ATI site there was a Catalyst driver date January 2003. I have often thought that this might be the probelm though I am not sure.
 

Sazar

F@H - Is it in you?
Staff member
Political User
#4
Originally posted by Engineer
I just got a new video care, ATI Radeon 9500 Pro, 128 MG and a new Samsung Syncmaster 955DF FlatScreen monitor.

Since the install, I have had the following problems,

When surfing the web IE locks up or the computer boots up,

When Running 3D games I get some weird white graphics in the trees (in the game) and the game will lock up or boot me back to my desk top.

Did not have problems before this installation and I do not think it is the monitor.

1.6 Ghz, P4 Intell
Gigabyte Titan MotherBoard
512 RAM

Any help would be appreciated. thanks
the new drivers are basically to fix open GL problems some people's setups... I doubt that would apply to IE... but might to the games...

now when you installed the card did you do a complete format and clean install of your OS ? its possible that older drivers might be bugging your system...

also check out the tech forums @ www.rage3d.com for problem solving related to 9500 series... that is basically the official un-official ati tech support channel... ati engineers hang out there...

basically try out the NEW cat 3.0 drivers and then if that doesnt work and you have not formatted... go ahead and try that out...
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,962
Messages
673,247
Members
89,020
Latest member
saryrehgy