Optical drives vanished?

teejay

OSNN Newbie
Joined
Apr 18, 2007
Messages
3
Upon booting up of my PC with Windows Vista i found that neither of my optical drives are recognized by the operating system. My systems is a P4, 1GB RAM, Nvidia pci 5500 video card, Creative Audigy, netgear ga511 NIC. The optical drives are: Lite-On LTR-48124 CDRW and a Pioneer DVD-RW DVR-111D. Both of these drives were working yesterday when I shut down. When i check the device manager I can see the drives listed under the DVD/CD-ROM drives category and both have Yellow ? next to their descriptions.

Wnen I open each drives Properties windows there is a messgae there stating "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing" (Code 39). Click "Check for solutions" to send data about this device to Microsoft and to see if there is a solution available". After clicking the "Check for solutions" box a windows pops up saying "Windows is collecting more information about the problem.

This might take several minutes" Then a minute later another box pops up saying "Do you want to send more information about the proplems?" I send the information and then the drives properties box is back up with no solution to my problem.

Does anyone know how to get the original drivers back for these optical drives? I would really appreciate it. Thanks ! TJ
 
Last edited by a moderator:

Sazar

F@H - Is it in you?
Staff member
Political User
Joined
Apr 12, 2002
Messages
14,905
Welcome Teejay.

I just cleaned things up a little bit to make it easier to read.
 

American Zombie

Administrator
Staff member
Political User
Joined
Jun 23, 2004
Messages
2,953
While in device manager, right-click on your drives and choose uninstall then let windows reinstall them.
 

teejay

OSNN Newbie
Joined
Apr 18, 2007
Messages
3
Hi, I tried uninstalling the drives but they still come back as unrecognized. Thanks though.
 
Last edited:

Racer_600

OSNN Junior Addict
Joined
Apr 7, 2005
Messages
39
I had the same problem, method 1 worked for me.
http://support.microsoft.com/kb/320553
I also had a buddy who installed easy cd creator and had the same problem. edited the registry too and his reappeared. Mine only had lower limits to remove but not upper.
Matt
 

teejay

OSNN Newbie
Joined
Apr 18, 2007
Messages
3
Thanks Racer. I will bookmark that page in case it happens again. I just re-installed Vista (had to install XP first since the Vista Ultimate was an upgrade DVD). Everything works again fine but I will have to create a restore point and back here this week before something else goes haywire. Thanks again. TJ
 

Members online

No members online now.

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Hey ep!

All good with me, applying for microsoft mvp right now, should have done this a while ago.

Notifications don't work, I only found your response by comming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier, mine is perriscalderon at gmail
Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...

Forum statistics

Threads
61,993
Messages
673,362
Members
89,035
Latest member
adreinrich