IPCONFIG Problem

omg its nlm

lvl 17 Hax
Joined
Jan 10, 2004
Messages
1,829
I have a user that when he does an ipconfig here is what happens....

C:\Documents and Settings\cliff.robbins>ipconfig
Windows IP Configuration
An internal error occurred: A device attached to the system is not functioning.
Please contact Microsoft Product Support Services for further help.
Additional information: Unknown media status code.
C:\Documents and Settings\cliff.robbins>


Any Ideas?
 

fitz

Woah.. I'm still here?
Staff member
Political User
Joined
Apr 26, 2004
Messages
4,084
more specifically, how many network cards are present? What OS? Did the system get upgraded fron 2000 to XP? Are there any modems connected? Are these setup for DHCP or static?

Have you tried removing and reinstalling the network drivers and/or network stack?
 

omg its nlm

lvl 17 Hax
Joined
Jan 10, 2004
Messages
1,829
There is a wireless card and that is when this happens. XP Pro of course. Everything is auto detect.

Yeah I did the driver updates. I had this issue once in the past with a user and I updated the drivers and it worked for a day and then it broke again.

Its an IBM T41
 

kcnychief

█▄█ ▀█▄ █
Political User
Joined
Apr 8, 2005
Messages
16,948
I would be sure the "Workstation" Service is set to Started, ran into this the other day I think.
 

kcnychief

█▄█ ▀█▄ █
Political User
Joined
Apr 8, 2005
Messages
16,948
Is there an error with an error code in the event viewer around the time you try to run IPCONFIG?
 

fitz

Woah.. I'm still here?
Staff member
Political User
Joined
Apr 26, 2004
Messages
4,084
I am having the user do a netsh to reset TCP/IP and see what that does.
this would have been my next sugestion.

Does this only happen when the wireless card is enabled?
 

omg its nlm

lvl 17 Hax
Joined
Jan 10, 2004
Messages
1,829
Well its still not working. I had the user also reinstall his drives. I am not to sure. I think it only happens with his wireless card enabled. I am checking on that right now. Any other ideas?

Per User -
If I have a wired connection, IPCONFIG works. When I have both a wired and wireless connection, IPCONFIG also works then and reports both IP Addresses.
 
Last edited by a moderator:

kcnychief

█▄█ ▀█▄ █
Political User
Joined
Apr 8, 2005
Messages
16,948
So if IPCONFIG works both ways and reports a valid IP, what is the problem?
 

Members online

No members online now.

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Hey ep!

All good with me, applying for microsoft mvp right now, should have done this a while ago.

Notifications don't work, I only found your response by comming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier, mine is perriscalderon at gmail
Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...

Forum statistics

Threads
61,977
Messages
673,276
Members
89,052
Latest member
KateBentley