• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

How to setup FTP server on a LAN...

G

Gizzy

Guest
#1
Hi Guys,

I want to setup an FTP server on my PC, this PC is connected to a router among others.. There is fixed IP address, and the other connected PC get an IP assigned automatically.

So, the IP address range it:

- 192.168.1.(10...255)


I have tried many FTP servers, Serv-U, WS_FTP Server, Bullet proof.. But they all get connected to the router, instead of the PC where I am hosting the files.

Can someone tell me, how do I bypass the router and get connected to the PC instead.

I always get the 'Router web configerator' log on screen, which asks me for a user name and password.

The Router is a Dreytek 2200E with active firewall.

Any help will be much appreciated.

Thanks.
 
L

Lithium

Guest
#2
well either you have to open the ports for the ftp which it 21 i believe or make the host computer the DMZ host
 
#3
You're obviously doing something wrong. How can you get the router config if you access an FTP??? It's not even the same protocoll.

So this FTP server is for internal use only? If so, just set up the server, then enter that computer's IP into the FTP clients of the other computers. As easy as that. If you use a browser as an FTP client, you must enter ftp://user@192.168.1.3 if you're FTP server is on 192.168.1.3.

If the server is for external use you must forward port 21 to the FTP server. The external clients should enter your external IP, not 192.168.1.3.
 
G

Gizzy

Guest
#4
Originally posted by Lithium
well either you have to open the ports for the ftp which it 21 i believe or make the host computer the DMZ host
I tried that too, didnt work!
 
G

Gizzy

Guest
#5
Originally posted by Zedric
You're obviously doing something wrong. How can you get the router config if you access an FTP??? It's not even the same protocoll.

So this FTP server is for internal use only? If so, just set up the server, then enter that computer's IP into the FTP clients of the other computers. As easy as that. If you use a browser as an FTP client, you must enter ftp://user@192.168.1.3 if you're FTP server is on 192.168.1.3.

If the server is for external use you must forward port 21 to the FTP server. The external clients should enter your external IP, not 192.168.1.3.
No, The FTP server is for external use. Not for use on the LAN.. For PC's connected to the LAN, I have file sharing enabled, so dont really need FTP access. But I want to share some files with a few friends on the net, so I want to give FTP access to them.

It should be both either FTP or through a Web browser.

and as you said, I tested it myself, by entering the external IP address in the browser, but I always get the "router web configerator" log on box..?

What am I doing wrong?
 

Henyman

Secret Goat Fetish
Political User
#6
i use ws_ftp and it works fine off my computer. i aint tried doin it through a lan though:huh: it does conect through post 21 so make sure it's conecting right. have u tried entering username/password in the web configerator log on screen?:cool:
 
P

PseudoKiller

Guest
#7
I run an ftp on a lan...
What is needed is for you to forward port 21 from the router to the ip of the ftp server. Make sure the ftp server is listening on that lan ip.
Hope this helps...
 
G

Gizzy

Guest
#8
Originally posted by PseudoKiller
I run an ftp on a lan...
What is needed is for you to forward port 21 from the router to the ip of the ftp server. Make sure the ftp server is listening on that lan ip.
Hope this helps...
How do I do that..? :eek:
 
G

Gizzy

Guest
#9
Originally posted by PseudoKiller
I run an ftp on a lan...
What is needed is for you to forward port 21 from the router to the ip of the ftp server. Make sure the ftp server is listening on that lan ip.
Hope this helps...
Ok this is how I have set the port forwarding..?
Im not sure if it done correctly.
 
#10
DeeEnEs Dynamic DNS

I'm guessing is that you want to give outside access to your internal ftp server. I'm going to use my Linksys router as a reference point to explain how to set up your ftp.

Getting Started
1. You must set a static IP address on the server, 192.168.0.2, 192.168.0.3,etc. Your router is set to 192.168.1.1
2. Once the static IP address has been assigned please go to your desktop and double click on Internet Explorer.
3. Once "Internet Explorer" opens, please type http://192.168.1.1 into the "Address Bar" and click GO
4. Then "Enter Network Password"(if you have one set) window will appear. Skip user name and type admin (admin is the default password) as the password, and click OK
5. This will bring up the routers "Setup" section. Look under "Domain Name".
6. You will need to click on the Advanced tab to the very right. Once the "Advanced" tab comes up please go to the Forwarding tab.

Depending on your specicfic router you might see something with the following heading's. Underneath each heading is an example of what or how they should be configured.


Customized Application
FTP
SMTP
POP3

Service Port Range
20 ~ 21
25 ~ 25
110 ~ 110

Protocol
Both
Both
TCP

IP Address
192.168.1.3
192.168.1.3
192.168.1.3

I use a DNS client that works better then anything else I've tried with my router called DeeEnEs. I've provided a link to there site. You install it on the FTP server machine, set it and forget it.

http://clients.dyndns.org/windows.php

I hope this points you in the right direction at the very least.

Good luck,

o0RaidR0o
 
#11
Explorer uses passive FTP that will not work behind a router afaik (if I'm wrong please tell me). You'll have to use a proper FTP client that can use non-passive FTP.
 
P

PseudoKiller

Guest
#12
you can disable passive mode in IE by going into Tools > internet Options > Adanced Tab and in there somewhere is the check box....
 
G

Gizzy

Guest
#13
Thanks guys for all your help. its much appreciated.


The FTP surver on my PC is up and running, and works just fine.

And just for the info, It works for both Explorer and FTP client. :)
 
R

RabidPenguin

Guest
#14
FTP requires both ports 20 and 21. You do not need to enable UDP traffic ovet these ports. FTP uses only TCP.

passive FTP that will not work behind a router afaik (if I'm wrong please tell me). You'll have to use a proper FTP client that can use non-passive FTP.
If it did not work behind a router you would not be able to use FTP across the internet.
 
#15
Originally posted by RabidPenguin
If it did not work behind a router you would not be able to use FTP across the internet.
Mr picky...
I meant NAT router. With port forwarding. I thought it would work but I've tried everything. I can't get it to work.
 
R

RabidPenguin

Guest
#16
Originally posted by Zedric
Mr picky...
I meant NAT router. With port forwarding. I thought it would work but I've tried everything. I can't get it to work.
You just did not open up the proper ports. For Passive ftp you need port 21 open along with all the ports >1024.
 
#17
I believe I tried that. Btw, I can't use port 21 (I use 2100) since I'm not the only FTP server on the network. And I can't forward all ports to me fo the same reason.

Oh well, any other solutions?
 
R

RabidPenguin

Guest
#18
if you are using a port other than the standard ports ou need to tell the ftp client what port.

example:

ftp.someserver.com:2100


The :2100 at the end of the url tells it to connect to port 2100 instead of port 21.
 
R

RabidPenguin

Guest
#20
Originally posted by Gizzy


and as you said, I tested it myself, by entering the external IP address in the browser, but I always get the "router web configerator" log on box..?

What am I doing wrong?
Unless your router is capable of "Loop Back” then you can not use the external IP if you are on the LAN side of the router. Most consumer level routers will not do "Loop Back”.
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,016
Latest member
ernestrojasn