• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

CS/Direct3D

A

adamg

Guest
#1
Firstly, I realise its a relatively old game and has its quirks.
I already know that Direct3D does not seem to work very well with many Nvidia cards, but apparently Day of Defeat v1.0 looked better in Direct3D than in OpenGL. After switching to Direct3D (1280x960), i ran CS. It seemed to work fine. Then i ran Day of Defeat. And thats where everything screwed up. It hung at 'Initialising and downloading', and i had to hard reset. Now evertime i try to play CS 1.0.0.5 (1.0.0.0 still works for some odd reason) or any other CS mod it just hangs and a hard reset is required. It happened to me once before already, and reformatting was the only option. Uninstalling, deleting, reinstalling, overinstalling, installing in 2 locations, nothing worked. I just wonder if anyone knows a solution or if it has happened to them before.
 

Sazar

F@H - Is it in you?
Staff member
Political User
#2
Originally posted by adamg
Firstly, I realise its a relatively old game and has its quirks.
I already know that Direct3D does not seem to work very well with many Nvidia cards, but apparently Day of Defeat v1.0 looked better in Direct3D than in OpenGL. After switching to Direct3D (1280x960), i ran CS. It seemed to work fine. Then i ran Day of Defeat. And thats where everything screwed up. It hung at 'Initialising and downloading', and i had to hard reset. Now evertime i try to play CS 1.0.0.5 (1.0.0.0 still works for some odd reason) or any other CS mod it just hangs and a hard reset is required. It happened to me once before already, and reformatting was the only option. Uninstalling, deleting, reinstalling, overinstalling, installing in 2 locations, nothing worked. I just wonder if anyone knows a solution or if it has happened to them before.
what happens if you go back to using openGL ?
 
A

adamg

Guest
#3
I tried OpenGL again, tried Software again, and even tried Direct3D, but all stop at the same spot. also tried different resolutions.
 

Sazar

F@H - Is it in you?
Staff member
Political User
#4
Originally posted by adamg
I tried OpenGL again, tried Software again, and even tried Direct3D, but all stop at the same spot. also tried different resolutions.
try using a different driver set with your card...

I don't know what driver set you are using right now... but consider rolling back to around the 30.xx series and going from there... they were quite stable..
 
A

adamg

Guest
#6
it worked before using 44.03, but i dont think the drivers are the problem. and...

It happened to me once before already, and reformatting was the only option. Uninstalling, deleting, reinstalling, overinstalling, installing in 2 locations, nothing worked
 

Krux

Nissan Powered
#10
I would just like to remind you that CS is a HALF-LIFE mod CS uses the HALF-LIFE engine CS is NOT a stand alone game if it was not for HALF-LIFE there would be no CS.


also I thought Nvidia cards from the GF2 up ran D3D better then openGL. what kinda of video card are you using? also do you have Dx9 installed by chance? ive noticed with every system ive built and owned that has an Nvidia card that isn't Dx9 has issues after I have installed it. try to stick with Dx8 until you get a Dx9 card.
 

Sazar

F@H - Is it in you?
Staff member
Political User
#11
Originally posted by Krux
I would just like to remind you that CS is a HALF-LIFE mod CS uses the HALF-LIFE engine CS is NOT a stand alone game if it was not for HALF-LIFE there would be no CS.


also I thought Nvidia cards from the GF2 up ran D3D better then openGL. what kinda of video card are you using? also do you have Dx9 installed by chance? ive noticed with every system ive built and owned that has an Nvidia card that isn't Dx9 has issues after I have installed it. try to stick with Dx8 until you get a Dx9 card.
CS is available by itself :)

it is a retail standalone game... no SP.. only MP... but it is standalone... with an updated HL engine :)
 
A

adamg

Guest
#13
I usually format every 2-3 months, hopes thats not too often but thanks for the tip Bootsy.
I have a gf4-ti4200 and i installed directX 9a to see my 3dmark03, which was not too good (780). I also used the retail version of CS. Thanks for all the help guys
 

Members online

No members online now.

Latest posts

Latest profile posts

Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,015
Latest member
evaiwhitis