• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XP Install has lost my ME Boot up



I have (For the 2nd time) Installed XP Pro
When I did this first time around (When it was released) it recognised my existing ME boot and automatically created a multi boot config on startup.
I lost that XP install when I changed Mobo (BSOD on boot) and never bothered installing again till now.

This time I started fresh install on my second disk and formated it as NTFS.
It now just boots into XP.

I have done Recovery Console boot and BOOTCFG /SCAN and tried /REBUILD but it does not see the ME boot on the other drive.
I am using an Abit KR7A-Raid mobo with HighPoint drivers, I press F6 at setup and use the latest drivers and can in fact DIR the drives at recovery console.
When I was installing XP a few reboots came up with ntlldr error and I had to recover that and restarted the install.
Also on second install it failed on Welcome screen point with just a white dot top left of screen, if I left it a few minutes a NV4DISP.DLL loop message appeared, I managed to Safe boot and install NVidia 41.09 drivers and then it was fine.

I tried manually updating the boot ini with different RDISK values but entry would just show HAL.something missing.

So, any way I can fix this ?
config the Boot.ini manually ?
Have I lost the MBR ?
Do I have to do FIXBOOT ?
Something else.
Been MS Site and cannot find anything apart from using BOOTCFG/SCAN or /REBUILD

Hipster Doofus

Good grief Charlie Brown
Welcome to the forums. :)

When you installed xp this time did it pick up the ME install? If so What does the boot.ini look like? Copy & paste it here.


Odd, someone else that's had the "white dot in top left of the screen" boot problem. Stupid video card drivers and windows not knowing what to do about it. Anyway, I would first make sure that your WinME files are all still there. If they are, then yes, you will need to reedit your boot.ini file. I'm not sure what file the boot loader has to check, but perhaps you can maybe do a /fastcheck option, tho I could be completely wrong on this. The first thing you need to do is figure out what drive your WinME is on. Assuming it's on the first partition of your first drive (not on the RAID), I would guess at something like this:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows ME" /fastdetect
Someone that is running WinME (which is few and far between) might be able to help you a bit more than I can.

I wish this forum could handle long strings without cutting them up in odd places. :(


The multi(0)disk..... part is only used for NT systems. The line for ME usually would simply read: C:\="Microsoft Windows ME"


I don't know about that. He is using the NT bootloader after all. Besides, what if C: has been assigned to some other drive?


Thanks for some replies guys
To answer questions.

This time around it did not recognise my ME disk at all.
My XP disk is Secondary Master (New disk and added to free space)
My ME disk is on the IDE3 which is the first HighPoint IDE slot.
My Backup (Old system disk) is on IDE4, the other HighPoint slot.

I have already tried using each rdisk(n) but all fail with HAL thing.
Not tried adding /Fastdetect though.

My ME disk would not be my "C" drive I think, I can try adding just the C:\="Microsoft Windows ME".

Any other ideas ?
I have alot installed on there and want to refer/dual boot for a period while I get to grips with XP and migrate my apps.


Try putting the ME on Secondary Slave to access it so Windows XP can use it without messing with the Highpoint drivers (might be what's causing the HAL stuff).


I was going to try that last night but it got l8 so did not want to get messy with the reams of cables in my pc ;)

That may help BOOTCFG /SCAN find it but I obviously do not want that long term.
2 Main disks on same IDE when the extra IDEs are there and both ATA133 (My ME Disk is Maxtor).

The recovery console Knows the disks are there, I can view them.
It just does not seem to recognise the actual System on there. :huh:

I may try swapping them over completely to see if XP finds itself on HP slot and them maybe bootcfg will find the "standard" ide slot ME system.

Thanks for feedback, makes a change to find a forum where people actually try to help :eek:



I swapped my XP drive and ME drive over on the IDE slots.
Moved ME to Secondary Master
Moved XP to HighPoint IDE Slot

Booted XP CD in recovery Console mode.

Boot.ini was almost right, edited manually and now both working fine.

All I need now is a Win98 (freeware) program to allow explorer etc to read my XP NTFS drive.


You say that, and other people have said that...
But funnily enough I have had very little problems with ME.
Installed 100s things on it, had 30+ games on it and all fine.

Just gone to XP for extras and to allow me to do some coding for later OSs.

Only 3 things I disliked about XP was;
1. First time I installed it (when it came out) I shortly afterwards upgraded mobo and memory, XP basically was BSOD and nothing would recover it :huh:

2. Kept getting the nv4disp.dll bsod whatever detonator drivers I seemed to use.

3. Does not properly support A3D sound (on my old MX300) card without DLL patching and running games in compatibility mode (Requiring task manager to bomb process after exiting game)

I am hoping with newer hardware and SP1 that these issues will go away.. Although A3D is still a problem :confused:

Now gone to M-Audio Revolution for sound.


Glaanies script monkey
Political User
can't get mad at XP when it doesn't load after a motherboard change. Usually you have to reinstall because it is such a huge system change.

I never had problems with WinME either, I just didn't like the fact that M$ spent all of there time on Win2k instead of WinME, they should of put a disclaimer on the OS or not charged me 80 bucks for it.

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member