• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XP auto play

M

mbbice

Guest
#1
Running XP Pro..... and I used to have an auto play window appear whenever a new volume was recognized by the computer. When a CD, Zip Disk, or even a digital camera were plugged in a windows wizard-like interface would appear basically saying I found this info and you have these options. Something has diabled that function and I'd like to resurrect it. Anybody have any ideas. I have checked the Group Policy editor and "disable CD auto play" is not enabled...... any other possibilities? A registry key? Thanks in advance for any advice.
 
V

Vorpal

Guest
#2
Open Regedit and dow a search for "NoDriveTypeAutoRun"

You will find more than one of these (3 or 4 I think)

The value on all of these should be 95hex (145 decimal).


"This key, which is of type REG_BINARY, consists of four bytes. The first byte is a bitmask defining which drive types should be AutoRun. The other three bytes should be set to zero (0).

The bits in the bitmask correspond to these constants:
Type Bit
DRIVE_UNKNOWN 0
DRIVE_NO_ROOT_DIR 1
DRIVE_REMOVABLE 2
DRIVE_FIXED 3
DRIVE_REMOTE 4
DRIVE_CDROM 5
DRIVE_RAMDISK 6
Setting a bit in the bitmask prevents you from using AutoPlay with the corresponding drive type. By default, the value in the registry is 0x95. Bits 0, 2, 4 and 7 are therefore set, which means that drive types DRIVE_UNKNOWN, DRIVE_REMOVEABLE, and DRIVE_REMOTE don't use AutoPlay information. (Bit 7 is set to cover future device types.) Altering this registry value thus allows you to test Autorun.inf files from a floppy disk (DRIVE_REMOVEABLE), network drive (DRIVE_REMOTE), and so on. For example, to be able to test AutoPlay from a floppy disk, set the value of the first byte to 0x91 to enable AutoPlay for floppy disks. "
 
M

mbbice

Guest
#3
Thanks for the reply. I checked the registry... and I actually have five keys as you mentioned.... but only the first and last are of type reg_binary. The middle keys are reg-dword, and their hex values are 91hex/145 decimal. I have a limited understadning of the registry so I am some what ignorant of the structure of most of the keys.... do these sound right and also what should the reg-binary values be.... they look totally different from the reg-dword values? Is this just for autorun on the CD-ROM drive or will this re-enable auto-play even for USB devices like a digital camera as well? Because that function if what is missing too. Also... gotr any ideas what application would have changed the registry values to disable that function? Only thing recent I can think of is Roxio ECDC Platinum 5 plus all of there patches that went along with it. Thanks for your help.
 
P

Phantom_24

Guest
#4
Having the same problem !!

Except I can only find ONE of those keys and it's a DWord set at 0x000095.

The only MAJOR apps that I've installed lately are Photoshop 7 and OmniPage Pro 11, which is what I think would be my major suspect cause it had me re-boot and "set up" the system to work properly with my scanner.

Man this ones got me STUMPED !!!

:mad:
 

madmatt

Bow Down to the King
Political User
#5
Launch Explorer
Right click on the drive (such as your CDROM drive)
Choose properties
Click Autoplay (tab)
Select "Prompt me each time...."

Hope this helps.
 
P

Phantom_24

Guest
#6
This would help except....

The is NO autoplay tab....it's GONE....like Scarlet running from Rhett Butler....

Only I DO give a damn !

:rolleyes:
 
P

Phantom_24

Guest
#8
Thats a good question !!

I found a thread mentioning what reg key to turn on...that did NO good....stil no autoplay tab!

And I also uninstalled OmniPage Pro 11 since it was the one application in the last week (last time I remembered autoplay was working) that made me reboot so it could "set up" my computer to work properly with my scanner!! Man I hate this rogue software crap.....these morons ALWAYS gotta mess with reg settings they SHOULDN'T be!!! Wait till I get my hands on ScanSoft !!

Next option, since I've uninstalled OmniPage to no avail, and I restarted CD Clone sys tray to see if THAT could jump start my autoplay( didn't wotk either) ....looks like a system restore is in order! Man that restore thing makes me nervous !
 

madmatt

Bow Down to the King
Political User
#9
Okay, in all seriousness.

In Group Policy editor:

Local Computer Policy
Computer Congifuration
Administrative Templates
System
Turn off Autoplay should be DISABLED

If it is ENABLED then it won't be used.
 
P

Phantom_24

Guest
#10
Tried that...no good.....

It was set to "not configured" so I set it to disabled and rebooted (win 98 habit) ...still no go.

When Auotoplay is working, if you insert a disc and hold down the shift key, an app window pops up asking you if you want to disable something with autplay.....it mentions a shortcut key to re-open that option app. Does anybody know what keys it mentions ?!?!
 
#11
Try this.
Quoted from computing.net:
For some users, the autoplay feature in XP does not work properly. The autoplay tab in both cd properties and menus disappears. A resolution to this problem follows.
Ensure shell hardware detection is started and set on automatic in Administrative Tools > Services.
 
P

Phantom_24

Guest
#12
Xsiv.....you are a GOD !!!

Worked like a charm.....upon reboot....there was all my autoplay tabs and even the program icons for the discs in the drives !!!!

Thank you thank you thank you !!!

:cool:

Now I wonder how that got turned off...the last time I messed with services was WEEKS ago! And autoplay was working last week.....
 

Members online

No members online now.

Latest posts

Latest profile posts

Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,016
Latest member
doertilog