Discussion in 'Linux & BSD' started by AcftMecH, Mar 16, 2005.

  1. AcftMecH

    AcftMecH OSNN Addict

    ok, i switched distros to suse 9.2. using the ndiswrapper and the win drivers for my wireless nice, my nic is working.

    after i "modprobe ndiswrapper" the lights come on. all good. i go through the iwconfig (see below)...

    $ iwconfig wlan0 mode Managed
    $ iwconfig wlan0 key restricted s:<KEY>
    $ iwconfig wlan0 essid <ESSID NAME>
    $ ifconfig wlan0 up
    $ ifup wlan0

    ... it now connects to router and assigns IP. i can ping my router and even connect to its config page, but cannot get online. i can not ping the other machine on network either. I have tried a couple of things:

    -- route add default gw 155.25.xx.1 (router ip)
    -- added to /etc/resove.conf: nameserver 155.25.xx.1 (router ip)

    still no worky. dumb questions though...above it says "name server" is that supposed to by my essid name or anything like that or just strictly "nameserver"? also should the IP behind it be my router addy or my IP coming into my router that i am assigned from my isp?

    anywho... doing that, I am still not connecting... any ideas?

  2. X-Istence

    X-Istence * Political User

    you did not add the default route. Add it with something like this:

    route add default <ip of your router>
  3. AcftMecH

    AcftMecH OSNN Addict

    good gawd! Finally got it. I found a good read and instruction on this. It seems normal NDISWRAPPER install will get ya only close in suse. I puy in bold the stuff I had to do to fix it.

    I wish I had the website to give but atleast I copied it to save for the future. Thanks to whomever wrote this:

    it was too big to put in here so i attached it.

    Attached Files: