Windows Server 2003, Group Policy with wallpaper, wallpaper still exists

Punkrulz

Somewhat eXPerienced
#1
Hey guys (I just realized I start off every post the same way),

I'm having an issue involving Windows Server 2003, Group Policy on the Domain Controller, and a wallpaper that won't go away. A few days ago, one of the people I worked with wanted his new wall paper pushed out to everyone who logs in. Initially, I set it up to be applied to all of the user created groups on AD. There were a few users that weren't getting it, so I applied the GP to the entire domain.

Here at work, it isn't feasible to have the background applied because when we remote into that client's computers using the Administrator accounts (or what have you), we get extreme performance slow downs using RDP. I removed the group policy from the domain, leaving it at the user groups (Now it doesn't affect all users, including Administrator). This worked, for the most part. We then ran into an issue where we were still seeing the background on the domain controller (where the policy was applied from) for the Administrator accounts.

We're unable to change it, the policy is locking down desktop changes. My co-worker explained that deleting the entry from the registry should take care of it... though we still can't change the desktop background, we at least don't have the pre-existing background displaying. This worked for the Administrator account.

We have our own Administrator account that we use to connect to the computers. The same thing is happening there, but when I deleted the wall paper from the registry, it still constantly displays. I've tried gpupdate /force and everything, but didn't work. What can I do to enable it so that on the domain controller we will once again be able to change the background as administrator?
 

fitz

Woah.. I'm still here?
Staff member
Political User
#2
I believe there is a correspoding policy in the Terminal servers to remove wallpaper when using RDP.. let me check

edit: under computer config, admin templates, windows components, termianl services
"enforce removal of remote desktop wallpaper"

Now, this doesn't really solve the problem that the desktop is still there, but it should help when connecting with an RDP session.

Have you checked to make sure there is no local (as opposed to domain based) policy on the computer?

Have you tried reapplying the domain policy with the wallpaper settings turned off?
 
Last edited:

Punkrulz

Somewhat eXPerienced
#3
Under the local policy where the desktop options are configured for the local policy, everything is set to "Not Configured".
 

mingster

OSNN One Post Wonder
#4
Not to hijack this thread, but Im having similar issue, I set up a GPO for the users to all use the same wallpaper, not thinking of those that remote in. Now when they remote in doesnt bug them, but when they dont log into the server there background is big ugly blue. How can i set this up for them, so that if they arnt connected to the server they can change their image and if they are connected the policy is enforced?
 

kcnychief

█▄█ ▀█▄ █
Political User
#5
I would disable the policy for remote users.

I would assume the background you are pushing out is stored somewhere on your network, and when they are not logged in, which doesn't give them access to network resources, it is the "big ugly blue" because it can't find the background.

Plain English -

If you have a file on \\server01\users\backgrounds\background.jpg

They can't call up that file when not connected.

If the user is a local admin on their PC, they should be able to manually switch to another background when not connected. Then again, when they connect it will probably switch.

Not to be off topic, but why are people enforcing backgrounds anyways? I can see locking down to an XP default, but are you putting any information on there? Just a bit curious, if there is a productive reason maybe I will consider it as well ;)
 

Punkrulz

Somewhat eXPerienced
#6
There is no specific reason the backgrounds are to be enforced. Basically it's a more "professional" look. I'm doing this for a police department, and instead of having users select their fun, fancy, colorful backgrounds, it has been suggested to enforce a more police like atmosphere. I love the background that the user created, but that's just my personal taste. There really is no rhyme or reason that this is being applied, however. No beneficial nature.
 

kcnychief

█▄█ ▀█▄ █
Political User
#7
Well if that is the case, you may want to store the graphic on the local machine. This way when they disconnect from the network, they can still see it and the image will stay constant.
 

madmatt

Bow Down to the King
Political User
#8
Firstly, when using MSTSC (RDP) to connect to a computer you can customize what is displayed as far as wallpaper, themes, etc. These settings exist under the "Experience" tab (Press "Options" to see the tabs).

Secondly, when a user chooses a JPG image to use a background image Windows will recreate that image as a BMP file and store it under C:\Documents and Settings\username\Local Settings\Application Data\Microsoft\Wallpaper1.bmp -- so you may have to delete this file because it is cached.

Lastly, which I assume you have already attempted. Group Policy: User Configuration, Administrative Templates, Control Panel, Display, "Prevent changing wallpaper".
 
#9
What I have done (I had talmosrt the exact same issue because the remote users were not gettign the background image when not connected) is us a login script to pulll down the image.bmp to the C:\ drive of the pc/laptop. Then used group policy to enforce it. It seems to stick for the most part.
 

Punkrulz

Somewhat eXPerienced
#10
Firstly, when using MSTSC (RDP) to connect to a computer you can customize what is displayed as far as wallpaper, themes, etc. These settings exist under the "Experience" tab (Press "Options" to see the tabs).

Secondly, when a user chooses a JPG image to use a background image Windows will recreate that image as a BMP file and store it under C:\Documents and Settings\username\Local Settings\Application Data\Microsoft\Wallpaper1.bmp -- so you may have to delete this file because it is cached.

Lastly, which I assume you have already attempted. Group Policy: User Configuration, Administrative Templates, Control Panel, Display, "Prevent changing wallpaper".

Excellent, your local bmp cache file was correct, I had gone through and deleted this, and the next time I logged in the issue was corrected. I greatly appreciate it! :)
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,970
Messages
673,297
Members
89,016
Latest member
Poseeut