• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Windows media player problem

Fenris

OSNN Senior Addict
#1
I can't seem to get windows media player 11 to work right on my fresh install of vista and it doesn't show up in the program list to delete it. It freezes every time I open it up and itunes doesn't recognize that I have it installed at all. When I try to install another copy of windows media player 11 from there website it says I have a newer version running already and that I can't install the older one.
 

Bman

OSNN Veteran Original
#2
How fresh an install of Vista are you talking about. If I am correct the latest version of WMP is installed automatically with Vista. Meaning that you do not need to install anything, what have you done/installed/changed/hacked since Vista was installed.

Once that is determined we can think of solutions.
 

Fenris

OSNN Senior Addict
#3
Its done it from the moment I tried to use it, so within a few hours of installing it. I haven't really tweaked anything, only thing that might affect it would be something Ccleaner deleted. I didn't really care at first since I didn't plan on using WMP but Itunes wont convert WMP files to ACC without WMP being installed and for some reason it doesn't recognize it. I figured that maybe it just needed to be set up so I ran WMP and it just froze and has done that every time since.
 

Johnny

.. Commodore ..
Political User
#7
Go to the task manager and see if it is running. If it is, end the process and try to open it again. Also, have you tried to reboot your pc and try to run it again ??
 

Bman

OSNN Veteran Original
#8
I don't think it's possible that WMP could be corrupted from a clean install, the only way that would be is if your disc has something wrong with it. In terms of fixing it, no real idea but maybe trying System Restore as far back as you can go.
 

Fenris

OSNN Senior Addict
#9
Its the X64 version... I think I am going to do another fresh install once I beat crysis I don't want to lose the save file shouldn't be much longer till I beat it. Nothing really on here that I will miss everything is backed up on an external.
 

Johnny

.. Commodore ..
Political User
#12
Did you remove access to the program ???

Go to control panel/default programs/set program access. Then select windows vista and click o.k ... Then reboot your pc and try to access it again ...
 

Fenris

OSNN Senior Addict
#14
New discovery in the whole issue. It seems the windows media player thats in the program files folder works but the one in the X86 program files folder doesn't...whats the difference between these to folders?
edit...
answered my own question the X86 program files are for the 32bit programs and the normal Program files folder is for the 64bit... which means the 64bit version of windows media player works, but the 32 bit doesn't. Anyone have any idea why this is and also why Itunes wouldn't recognize that I have windows media player installed?
 

Fenris

OSNN Senior Addict
#16
lol well I figured that out already. Another question... When I double click on an item to play it in WMP it always opens up the X86 version how do I tell it to open up the 64 bit one?
 

Dark Atheist

Moderator
Staff member
Political User
#17
To switch and change to x64 or 64-bit of WMP11, open an elevated command prompt as administrator and type the following command:
%windir%\system32\unregmp2.exe /SwapTo:64

Then, open Registry Editor (regedit), then navigate to the the registry key of “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\wmplayer.exe”. Then set the registry subkey “Path” to be “%Programfiles(x86)%\Windows Media Player” (without quotes), and “(Default)” subkey (normally the first entry) to “%ProgramFiles%\Windows Media Player\wmplayer.exe” (include quotes).

To undo the x64 change, switch, swap, revert and change back the default media player to Windows Media Player 11 x86 32-bit edition, also open an elevated command prompt with administrator privileges, but issue the following command instead:
%windir%\system32\unregmp2.exe /SwapTo:32

Then, run Registry Editor, and reset the value for registry subkey of “Path” and “(Default”).
 

Members online

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,013
Latest member
Pdawgintown