Windows Management Instrumentation (WMI) ?

D

downunderground

Guest
#1
My computers are networked but wont share the internet connection. I tried reinstalling network drivers and the rest. In my Local Area Connection properties on one computer it says it cant display the information under the Advanced tab. It says the Windows Management Instrumentation information may be corrupted and suggests that I use system restore to restore to an earlier point. I tried this but had no luck. Is there a way to fix this WMI shit, maybe a download ? Any help would be great!!:p
 
R

Raven76

Guest
#2
Start menu >> Run >> type "sfc /scannow" without quotes.

Hopefully this will repair the WMI service. You should also try to stop and then restart the service and try again. Control panel >> admin stuff >> services is the place to do that.

Good luck.
 
D

downunderground

Guest
#3
No Luck

Thanks Raven,
I tried what you suggested but with no success. In Event Viewer I get an application error for Winmgmt and it is described as...

"WinMgmt could not initialize the core parts. This could be due to a badly installed version of WinMgmt, WinMgmt repository upgrade failure, insufficient disk space or insufficient memory."

Any ideas on how to reinstall these core parts other than using the sfc command? This is really starting to get on my nerves.
:(
 
E

everton

Guest
#4
WMI and ICS

I am having EXACTLY the same problem as downunderground.

Everything was apparently working fine and I was sharing the internet over the host (Win XP) to a client (Win 98SE) with no problems.

Then mysteriously internet connection sharing stopped working. Sharing files, etc over the network still worked fine. When I tried running the network setup wizard to re-establish ICS, it said there was an error meaning the wizard could not be completed.

Checking properties for the LAN and for the internet connection, like downunderground I noticed too that under the Advanced tab it said that it can't display information as Windows management information may be corrupted. It suggests using system restore to restore to an earlier point. I too tried this, only to find that whatever point I pick, when Windows restarts it informs me that the restore failed due to an improper shutdown! (which must be a problem in itself... I can't understand what is improper about the way my computer shuts down!!!)

:confused:

Anyway, I ran the system file checker ('sfc'), as suggested, but while it ran OK it didn't help. The network setup wizard still won't complete, and the connections properties won't display information in the Advanced Tab relating to ICS.

Does anyone have any suggestions short of reinstalling Windows XP? I have been using Windows XP for a few months but these seemingly inexplicable problems are irritating and almost make me want to go back to Win 98 SE!!!
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,971
Messages
673,299
Members
89,016
Latest member
Poseeut