Windows internet faster than Ubuntu, need help to fix

Heeter

Overclocked Like A Mother
Joined
8 Jul 2002
Messages
2,732
Hi all,

I am testing my connection to my ISP server. My ISP tells me that my connection speed should be as follows: 15Mbps download/1Mbps upload.

I have two HD's, one with a fresh install of Ubuntu8.10, and one with a fresh install of Windows7 beta7048. I am using the same machine (AMDPhenom9850BEX4, 4Gigs DDR2, Onboard Realtek gig network card)

With my Windows setup, I am hitting an average of 21Mbps Down/1Mbps Upload.

With my Ubuntu setup, I am hitting an average of 6Mbps Down/ 800kbps Upload.

I got the same results with my other ubuntuStudio 8.10 desktop (6MDown/800KUp)

Is there any way I can achieve the same results for my Ubuntu 8.10 as the Windows7?

Heeter
 

LeeJend

OSNN Veteran Addict
Joined
25 Jan 2003
Messages
5,291
There are some networking settings that need to be optimised for the windows registry. I assume the same is true for Ubuntu. DSLReports has a section explaining them. I'll go dig around for how to get at them in Ubuntu and update this post if I find them.

Check this:
http://onlyubuntu.blogspot.com/2008/07/how-to-optimize-your-internet.html

There is also a small chance it could be the NIC drivers ubuntu is using but I doubt that.

Now for grins I'll go speed test my machine on windos and ubuntu. Be back soon.
 
Last edited:

Heeter

Overclocked Like A Mother
Joined
8 Jul 2002
Messages
2,732
That would be great if you can find something like that.

Thanks LeeJend,

Heeter
 

LeeJend

OSNN Veteran Addict
Joined
25 Jan 2003
Messages
5,291
I'm baaack.... That took too long. Had to install Flash and Java upgardes.

The good news is your Ubuntu is probably fine.
I got 2483/412 with windows using the Flash 8 test.
I then got 1673/431 using Java test on Ubuntu WTF!
I switched to Flash on Ubuntu and got 2562/450! :)

Note: While downloading the Flash and Java updates I was showing a 341 MBytes per sec transfer rate which is around 2400 bits per second speed and as good as I ever get in windows downloads. That confirms the real speeds are the same.

Seems to be a problem with Java. Now I'll go reboot windows and run the test using the Java option there to see what happens..

This was fun. (I need to get a life.)

Update - Java and Flash were the same speeds in Windows. Must be a JAVA quirk with Ubuntu.

The instructions for optimising TCP/IP settings in Ubuntu are in the link I posted above. I doubt they make a big difference though.
 

assclown

OSNN Citizen Man
Joined
4 Jun 2005
Messages
80
How unfortunate, the open source doesn't work well with open... source?
 

Heeter

Overclocked Like A Mother
Joined
8 Jul 2002
Messages
2,732
I'm baaack.... That took too long. Had to install Flash and Java upgardes.

The good news is your Ubuntu is probably fine.
I got 2483/412 with windows using the Flash 8 test.
I then got 1673/431 using Java test on Ubuntu WTF!
I switched to Flash on Ubuntu and got 2562/450! :)

Note: While downloading the Flash and Java updates I was showing a 341 MBytes per sec transfer rate which is around 2400 bits per second speed and as good as I ever get in windows downloads. That confirms the real speeds are the same.

Seems to be a problem with Java. Now I'll go reboot windows and run the test using the Java option there to see what happens..

This was fun. (I need to get a life.)

Update - Java and Flash were the same speeds in Windows. Must be a JAVA quirk with Ubuntu.

The instructions for optimising TCP/IP settings in Ubuntu are in the link I posted above. I doubt they make a big difference though.

Thanks for the great research on that leejend.

Didn't even think to look there.

I agree with you on the settings optimization on that page. Doesn't look like it will do much difference.

I wonder how can I fix this.


Heeter
 

Heeter

Overclocked Like A Mother
Joined
8 Jul 2002
Messages
2,732
Thanks tdinc,

I did mention that I am using Ubuntu8.10. I also tried it with my UbuntuStudio8.10 with the same results.

I will try that as well,

Thanks

Heeter
 

Heeter

Overclocked Like A Mother
Joined
8 Jul 2002
Messages
2,732
Update,

I tried a flash speedtest with my ISP, no change.

I have disabled IPv6, some change, averaging out about 1Mbps more now, still nowhere close to the Windows 7 beta speedtest.

Any other ideas?

Heeter
 

Members online

No members online now.

Latest profile posts

Also Hi EP and people. I found this place again while looking through a oooollllllldddd backup. I have filled over 10TB and was looking at my collection of antiques. Any bids on the 500Mhz Win 95 fix?
Any of the SP crew still out there?
Xie wrote on Electronic Punk's profile.
Impressed you have kept this alive this long EP! So many sites have come and gone. :(

Just did some crude math and I apparently joined almost 18yrs ago, how is that possible???
hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.

Forum statistics

Threads
62,013
Messages
673,480
Members
5,607
Latest member
endryshall