• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

USB porrts not functioning properly

mfarley

OSNN Senior Addict
#1
This is a bit of an odd one...

I have an EVGA 122-ck-nf68. Recently when connecting my usb enabled Olympus digital camera my computer recognizes it's connected but I cannot access the card. It doesn't show up under my computer and when I type the address in it claims it cannot find it. However, I can go to safely remove hardware in the systray and it's listed. My camera acts as if it's connected as well. That's oddity #1.

#2 is, pretty much everything I use is USB...logitech mx laser mouse, microsoft ergonomic keyboard, etc. Both function IN windows but, when I go to restart the computer, the keyboard does not get recognized as attached. And having a dualboot setup with windows xp and vista I need to be able to select which os as 95% of the time I use XP and the dualboot defaults to vista. I rarely restart the PC, maybe once every couple weeks but I have to hook up my old keyboard using the serial port in order to get into xp. Then my usb keyboard works.

I've 6 usb ports, 4 in the back and two on my tower and all are acting identical.

I tried re-installing the drivers and that's done squat...and this is a recent problem mind you. It's been functioning properly for 3-4 months.

Any thoughts before contacting evga?
 

Aprox

Moderator
Political User
#3
I have a similar issue to this, whenever I plug in my camera windows recognizes that something has been plugged in (makes a sound) but I cant access the card. Also, the lights on my keyboard go out and it stops working. Its really quite odd, and I have tried everything you could probably think of to try and fix it.

Our issues are probably not related though... :) I think my cameras usb connection might be toast. As sometimes I get a error that pops up saying something about a USB power surge when I plug it in.
 

dreamliner77

The Analog Kid
#5
Is it possible that you have too many things connected to the USB ports and are pulling too much juice from them? Do you have a POWERED hub you can try?
 
#6
No, I have had it installed in the past...but I've written zeros to the drive and re-installed the OS, etc. since. So there is no residue.
ok, cause the SPTD driver which Alcohol uses nukes all the USB ports on my desktop machine, so I've had to remove Alcohol completely.
 

mfarley

OSNN Senior Addict
#7
Is it possible that you have too many things connected to the USB ports and are pulling too much juice from them? Do you have a POWERED hub you can try?
I wouldn't think so as at most I have my keyboard, mouse, and camera connected. And that wouldn't resolve the fact that my keyboard refuses to register as connected at all in BIOS.
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,962
Messages
673,247
Members
89,019
Latest member
fontjohnson