• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

USB hard drive.

#1
I have been handed a usb HDD to see if i can get it working. Basically it was working now he cannot access it. I have tried to get it to work but no avail. It has its own power supply. I power it up, plug the usb cable in to my pc(and various other) it starts to load the usb drivers etc and gives the old ding dong sound. Now once it has installed i cannot find it. My computer shows no sign of it ,it doesn't go through the usual AUTOPLAY feature. BUT!! if i goto device manager it is there in black and white and no problems found. The HDD is a maxtor 6Y120LO, diamondmax plus 9. He has alot of personal and work related files on this drive and doesn't want to lose it. Any advice on how to be able to retrieve these files and then bin the drive.
 
#3
Sounds like the drive partition got wiped. In device manager, but not in windows sounds like a drive that is not partitioned.

If you have one, try a HD recovery tool to see if the FAT can be restored. If there is no important data on the drive try partitioning the HD. If you can't access it in the case do waht drz said and pull it and try it inside the PC.
 
#5
It is USB only,its a fairly old one(basically just a pc HDD), i have tried it directly into the ide cable on a desktop pc to get the results explained.
 

Stevai

OSNN Junior Addict
#6
Out of curiosity, does it show up if you look in the Storage snap-in? I know you cant restore it from there, but before I get going, wanted to know if it shows up there.
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,015
Latest member
oggeytom