• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Unmounting Issue


OSNN Veteran Original
For awhile now I have had an issue with Daemon tools. It might be Windows 7 related but not sure.

Basically if I unmount an .iso file, it goes away like it should, but if I try to move or delete that just used .iso file, it says its being used. The only way I can move or delete that file is to mount another iso.

I can't find any posts about this on daemon forums. Ideas?
I just tried it with the latest Daemon Tools Lite v4.35.5.0068 (which is the first one that is Windows 7 compatible). I mounted an ISO, then unmounted the ISO and then successfully moved the ISO file to another folder without any problem.

Are you using this version or one of the paid versions or what, and is it the latest of whichever variety it is? Have you tried not only unmounting but also removing the virtual drive and see if it lets you then. It wasn't necessary for me, but who knows...

Do you have any other software installed which might automatically scan the drives for discs (AnyDVD, My Movies Media Center movie database - highly recommended BTW, been using it since v1.0)? Don't know if any of them might interfere, particularly if the ISO is a movie.


OSNN Veteran Original
I have the latest Lite version, the one stated. I do have AnyDVD installed but it's never open, its only used when I need it. I don't see any other software running in the background that would cause issues.

It's been like this for awhile, every single iso or mountable file I can find does it.

Though I just looked at how I do it each time, and I actually don't hi unmount, I hit Eject. Could that be it? Is it different then unmount? I just noticed that you need Daemon Tools running to unmount it, what I normally do is right click on the ISO file and open with, and choose daemon tools. That mounts it, does not open the program.

Is there away to choose unmount without opening Daemon tools?
Hmph. You got me, but that's just as good as any as a possible cause. Why not at least just try "properly" unmounting it through the program just once and see if it behaves correctly then or if it's some deeper issue that affects it anyway. At least then we've eliminated something.


OSNN Veteran Original
Yup, works perfectly through having Daemon Tools being open. Darn, that is a hassle to have an extra program running at all times. Or to open it when I need it.
I know, I hate to have things running that I don't absolutely need to, but anymore I just leave the Daemon Tools gadget on my desktop for quicker access. Some people don't like anything at all on their desktop, of course. I just set my four gadgets to 20% opacity. At least you figured it out.

Are there command line options for Daemon Tools and can you make batch files/shortcuts to do what you need it to do?


OSNN Veteran Original
If there any I don't know them. Anything would be more effort then I would want.

I guess I will deal with opening up Daemon Tools when I need it.

I just noticed that you need Daemon Tools running to unmount it, what I normally do is right click on the ISO file and open with, and choose daemon tools. That mounts it, does not open the program.
I was trying to mount ISOs the same way as you described and I was wondering if I was missing something because I get "Error in command line." when I right click on the ISO and chose Open With DTLite.exe (DAEMON Tools Lite in the Open With menu). I tried the other two exe's in the Daemon Tools Lite folder in Program Files and they don't do anything at all. How'd you get this to work?

Here's the batch file you need. Very simple. Just put it where you want it, name it what you want, and you could create a shortcut to it, choose Properties for the shortcut and set the icon for it to point to Daemon Tools Lite's icon.

It will unmount ALL images you currently have loaded, in case you have more than one virtual drive active and mounted at the same time. We could do fancier things like create different batch files for unmounting specific drives, et cetera.

Then it will force kill the DTLite.exe process. DTLiteShellHlp.exe will still remain running, it appears to stay running as long as DT is installed, even trying to kill it didn't work, at least not from the Task Manager, although I didn't try the force kill option from the command line like I did to DTLite.exe in the batch file.

We could make it fancier and use environment variables in case your Windows is not on the C: drive as well.

"C:\Program Files\DAEMON Tools Lite\DTLite.exe" -unmount_all
taskkill /IM “DTLite.exe” /F
As usual with Windows when the process is killed the notification icon will "appear" to still be active but when you hover over it with the mouse it will simply disappear. This is normal. I have the DT notification icon hidden anyway.





Enjoy! :)



OSNN Veteran Original
Interesting, thanks for that. I was going to create that, but thought it's more effort. Then again, it's less effort then opening DT, right clicking and finding the drive, and then unmounting. This is just clicking it. So I will use this. Thanks.

And to how I got my way to work, don't know. I installed DT, and that is just how I have been doing it, at least since Windows 7.

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member