TV tuner will not install



I got a deal on a Leadtek TV2000XP tuner and tried there latest drivers without success. When installing them, I continue to get

"There was a problem installing this hardware: Multimedia Controller, An error occurred during the installation of the device, The data is invalid".

I havn't got a clue on where to isolate the problem.
There doesn't seem to be any IRQ or force hardware situations at all.

I was able to install it in another system with XP without a problem but it will not install on my main system.

Any suggestions?

IRQ 0 System timer OK
IRQ 1 Standard 101/102-Key or Microsoft Natural PS/2 Keyboard OK
IRQ 3 Communications Port (COM2) OK
IRQ 5 WinFast(R) A250 Display Adapter OK
IRQ 8 System CMOS/real time clock OK
IRQ 9 Microsoft ACPI-Compliant System OK
IRQ 10 3Com EtherLink 10/100 PCI For Complete PC Management NIC (3C905C-TX) OK
IRQ 11 VIA Rev 5 or later USB Universal Host Controller OK
IRQ 11 VIA Rev 5 or later USB Universal Host Controller OK
IRQ 11 Windows XP Promise FastTrak100 (tm) Controller (PDC20265) OK
IRQ 13 Numeric data processor OK
IRQ 14 Primary IDE Channel OK
IRQ 15 Secondary IDE Channel OK

I called technical support on the subject with no results. I even tried to install the drivers in safe mode with no luck at all.

PS. XP does recognize that there is a multimedia hardware device to be installed but when trying to install them, the above mentioned error occurs.
I just went to the leadtek website. I notice they have a new driver package out dated 2002/4/16. Are these the ones you're trying to install?

Also, try to put the card in another slot and see what you see.


Thank you for the quick reply but the drivers are not the problem. However, I did a search on this site and found a solution by Barbarian :


This is a fix for if you ever had a "data invalid" problem that nags you while you were installing and swapping out cards with Windows XP.

This error appears to be due to a protection problem in the Windows registry and can occur with a variety of drivers (sound cards and SCSI drivers have been reported). To fix this problem, go to Start, Run... and type "regedit" without the quotes to run the Registry Editor. Navigate to


and you will see a number of keys of the form "VEN_xxxx", where xxxx are strings like "1102&DEV_0004&SUBSYS_00011103&REV_04". Under each of these folders will be another folder with a long numerical name. Open each folder and look for the "DeviceDesc" which matches the hardware you are trying to install. Right Click on the "VEN_xxxx" for that device and select 'Permissions' and then tick "Allow" for "Full Control". Close Regedit and then continue with the installation of your device.
I cannot guarantee it works for everyone, but although I swear by it after swearing at it(XP), it should help you if you ever had casual problem.
I am very happy:)


Barbarians advice worked as mentioned, except for one strange occurance. My sound on the TV tuner stops working when I execute Outlook Express or Windows Messenger.

When I shut down the tuner and turn it back on (while those programs are active) it works.



Tha last problem is interesting...
The sound on my TV-Go stops if I open or close my cd rom...


Originally posted by MiseryQ
Tha last problem is interesting...
The sound on my TV-Go stops if I open or close my cd rom...
I'm assuming that when either the application (or in your case the cd rom) is engaged then an executable program is set in action that partakes in using the same audio codecs as that of the tuner. But then, if no audio is set in action, shutting down the application should allow the tuner to work.

Is there a doctor in the house that can shed some light on this?:)