Strange ICS problem


Staff member
Political User
I've just bought a Belkin network card for my dad's PC and installed it, so that he can share my broadband connection using ICS. I've been sharing this connection successfully with my brothers PC so I know that it works. However, after a few attempts, I managed to get my dads's PC (Which is running XP) connection to the internet, but it is EXTREMELY slow, like 1kbps so is in essence not working. Also, in the network places, there is no icon for the shared internet connection like there is on my bro's PC. I've run the network connection wizard many times, but no luck. I ran IPCONFIG from the cmd promt, which all looks normal, in any case it's the same as my brothers but with a different IP obviously. Has anyone had any problems like this?
I'm running SP2 on mine and my brothers, but just XP on my dad's. Will this affect it? Any clues will be greatfully appreciated, reps for anyone that can help.

Also forgot to say, I am using a cable modem router but I turned it into a switch for ICS. I can't use it as a router cos I have ADSL and it's a cable router.


OSNN Veteran Addict
How is it configured?

ADSL into your machine which acts as the DHCP server and assigns Internet adresses. 2 NIC's in your machine one to the modem the other one into the cable modem which is just acting as a switch to feed your dad and bro?

If this is what you did the cable modem may be the problem. Swap the wires going to your dad and bro and see if the slow connection changes between them.

What you really need to do is spring for the $10-20 and buy a router. Hook it between the adsl modem and the rest of the computers. If the ADSL modem is a card in your computer then put the router between your second nic card and dad and bro.

If you really want to splurge pay $20-30 and get a router with wirelss G and you can try and tap into a neighbors boradband so you don't have to share with dad and bro. ;)

It's Memorial Day weekend and the router sales are flourishing.


Staff member
Political User
Sorry I wasn't very clear with that post. I use a USB ADSL modem, plugged into my computer. I have one NIC in my computer, which I use to connect to my router, which is in effect just a switch. (I remember doing something to it so that it acted as a switch a while ago, but forgot the details). My bro and my dad both connect using their NICs to the router. Pretty much identical set up with both computers. My brothers is fine, but my dad's just won't have it, I've tried configuring the network manually and also via the network wizard but I can't get it to connect properly to the network. It either won't work or is incredibly slow.
It's all running at 100Mbps.

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member