• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Something broke the DMA setting to my Toshiba 12x DVD drive !!!

P

Phantom_24

Guest
#1
Now I'm stuck in PIO mode hell !!!

Anyone know how/where I might find a fix for this without having to REFORMAT ?!!!!!!

Please.....with sugar on top !!

:(
 
P

Phantom_24

Guest
#2
My Sony 8x burner is ok though....

My Sony 8x, which is also on the same channel, is working fine in DMA mode....as far as I can tell (this is all for Win XP Pro btw).
The Sony is set for Master and the Toshiba is set for Slave. This was all fine as long as I can remember, at least up until I installed XP SP1 or later.....The final release that is!

Hmmmmm.......
 
P

Phantom_24

Guest
#3
Possibly my ATI DVD software??

The last time I used my DVD drive for movies was before I installed the ATI 7.6 player (had the 5.x player installed originally which had DMA just fine), and have since upgraded to the new ATI 7.8 player in hope to fixing the DMA issue, but this didn't do the trick.
 
R

Rootz

Guest
#4
This is not a software problem...
You can set hardware transfer mode from
ADMINISTRATIVE TOOLS/COMPUTER MANAGEMENT/DEVICE MANAGER
Expand IDE CONTROLLER then rightclick the channel you want to change data transfer mode for and choose PROPERTIES/ADVANCED SETTINGS
there you find all available data transfer modes. Set as you like.

If you are forced to one mode only and others are greyed out or not available then you are in big trouble
:)
 
P

Phantom_24

Guest
#5
Already tried this...no go!! Though I do have to say I saw this before back in Win98...and I was hoping I'd never see it again in WinXP!! But is has SOMETHING to do with something screwing up the OS because as I've said, I've seen this before and a reformat ALWAYS fixes it!! The Hardware is fine (mobo, drives and all other hardware...). All is working just fine...it's just that something is telling the OS that my Toshiba drive is not DMA compatable...which it IS.....even Toshiba says so.....
 
P

Phantom_24

Guest
#7
Unfortunatly...my Abit BF6 is tapped out for BIOS updates some time ago....this is just annoying though....cause my DMA worked for my Toshiba drive for some 6-8 months on XP....guess I'm gonna have to consider a format session sometime in the near future....

Doh !!

Thanx again though Rootz for the help......
 
#8
This should help if you still have the problem

It worked for me and many others...posted same solution before in here always try a search first m8.

Open REGEDIT and find the following keys:

HKEY_LOCAL_MACHINE\SYSTEM\currentcontrolset\control\class\ {4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

Last four digits are likely 0001, 0002. Under those keys you will find MasterIDdataChecksum, SlaveIddataChecksum. Delete the value corrosponding to your drive.It will make th OS redetect the drive DMA capabilities after rebooting.

If it works for you too please say so...thanks.
 
#9
just thought better add more instructions

right click on the master and slave checksums and then choose modify and delete the value data box contents do this to both 0001 and 0002 lines.
 
P

Phantom_24

Guest
#10
Sweet fix Bony!!! That did the trick !!

Bonsai !!!

Guess MCSE training doesn't show the techs ALL the bugs Windows has.....heheheh...sorry Rootz!!

:)

Just that I've seen and had this problem several times over the last few years...though I still think some other software did this hogwash......
 
R

Rootz

Guest
#11
No it doesn't... virtually impossible!
Actually it's me also... I don't like getting too much into the registry 'cause causing big trouble it's the easiest down there (more often if you casually modify keys expecting the system to restore values by itself) and actually never needed so hardly.

I'm happy you fixed your problem but if I were at work or you were a friend of mine I would have never adviced you to do something that may screw system components, data or hardware management... you might have damaged the registry, means you could get no fix at reboot more than a... no reboot!

Anyway good going BonyTony, the important is having the problem fixed in the end!
:)
 
M

Mr Dead

Guest
#12
My Solution

Ive had this problem a few times caused by read errors when ripping a scratched dvd. If several read errors occur in a short time period windows automatically forces the device into PIO mode and it cannot be put back into DMA (even if you select "dma if available). Ive tried the reg hack before but it didnt work for me. The only solution ive found so far is to swap the drives master/slave settings which solves the problem...
 
P

Phantom_24

Guest
#13
Well...I want to heartely thank EVERYBODY for there sound advice....even if it seemed a bit extreme!!! Hey, what fun is an OS if you don't want to screw around with it once in while......hehehe!!! I'll admit I've done my fair share of registry hacks...though mostly from here....and haven't gotten burned yet....THAT'S why I love this site and it killed me when it was down!!

Now.....does anybody have a fix for why XP won't eject my CD-Rom/DVD's after I view/run programs from them, unless I reboot ?!?!?!?
 
#14
no but......

I have a handy tool that you can have that sits in your system tray and you can select a hotkey to either eject or eject on a 5 second counter then closes again.....only 200k new version free as well ....ps is it a liteon drive ?
 
P

Phantom_24

Guest
#15
Does it on BOTH drives!! One Sony 8x4x32 CD-RW...and the other is a Toshiba 12x DVD. Both are EIDE and both won't open unless I reboot, after viewing/running files from EITHER drive!!

Hmmmmmm......

:confused:
 

Members online

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,962
Messages
673,240
Members
89,015
Latest member
loxioalix