Slow load on system processes after logon


OSNN One Post Wonder
Ok I bought a new WD 74gb SATA raptor HD. I decide to backup all my important files on a few DVDs. I format my old hard drive, load the drivers for the raptor and use it for windows and my main programs. Everything loads up fine, windows install extremely fast.

After everything is installed I'm amazed at how fast windows boots up. Takes maybe 10 seconds, and thats after the 5 seconds my mother board takes to detect my SATA drive. I install my linksys ethernet card drivers, reboot. As soon as I log on I try to create a connection. I click on network places, then try to click on network connections. The folder seems like it freezes up. So I pop open my task manager, and the damn system processes are still loading. I sit there for a few minutes, and finally after about 3 minutes they finish loading and my network connection folder finally opens.

For some reason I remember having this same problem in the past. I went ahead and installed all the windows updates hoping that might help. Then I disabled all the services that are resource hogs. Set NOGUIBOOT in msconfig, set up my swap file on a seperate partition, do a few more things I can think of to speed it up. Still it takes forever to load the system processes after logon. I just don't understand it, I wouldn't think it should take 30 times as long to logon to windows as it does to boot it up. Even on my old slow ass WD HD my logon was almost instantaneous.

A few specs

Athlon XP 3200 Barton processer
Giga-byte GA-7n4000 Pro2 nForce2 ultra 400 Mobo
2x 512mb corsair pc-3200 dual channel ram
ATI 9600xt 128mb video card
WD 74gb SATA raptor 10,000rpm HD(boot drive)
WD 80gb IDE 7,200rpm HD(used for media files only)

Not the best, but not slow. Just doesn't make sense to me why it's taking so long to load the processes. Maybe a setting I need to change for SATA drives? I don't know, any help would be very much appriciated though.
Network related for slow logon. Remember your settings in case in doesn't work for you." Click Start / Run / mmc, then File / Add/Remove Snap-in and add the Group Policy snap-in. Navigate your way to Computer Configuration / Administrative Templates / System / Logon and change Always wait for the network at computer startup and logon to Enabled.