• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Slow file transfers with XP...

D

Dreamworld

Guest
#1
I have 2 computers running XP and 2 machines in another room running Win 2k (all 4 ran Win2k before).
Problem: When transfering files between a Win2k machine and an XP machine, or between the two Win2k machines, everything moves along nicely at 100 Mbps.

BUT when transfering between the XP machines it's S L O O O W WWW..... (100 MB file takes about 4 minutes, compared to about 15 sec on the others.)
Ideas?

The network cards and hard disks must be OK since they perform flawlessly when talking to the Win2k machines.
 

gonaads

Beware the G-Man
Political User
#2
Do yu have the native XP Firewall active? Are yu runnin any other Firewall Proggy. The XP Firewall seems to slow down the fill transfer, well that was my prob anyway. I disabled it and am only using Zone Alarm Pro.
 
N

neoterixx

Guest
#4
*BUMP* My friend is also having trouble with this, sometimes it takes him some outlandish times to move data over, anyone know why ?
 

Reg

eXperienced!
#5
This is a common problem with XP to XP transfers. It happens because Windows XP periodically checks the line speeds (QoS) and adjusts the machines performance to match the line (for optimum performance). The problem is that one XP machine may have different readings and adjustments than the other. When you initiate a file transfer, the two machines have to readjust to each others readings. Most of the time, the machines drop to the lower reading for more compatibility. The result, lower file transfer speeds.

This problem is more common with users who use shared mediums for networking (such as hubs). If you are using a hub, try using a dedicated medium such as a switch. This way, the line speed stays constant.
 
D

Dreamworld

Guest
#6
Thanx for all the help so far!

I am using a switch here.. My 2 XP machines are connected to a switch, which in turn are connected via the "Uplink" connector to the rest of the network.

XP reports 100Mbps, as does the LED indicators on the network cards and the switch. Hmmm..
 
D

Dreamworld

Guest
#8
OK.. Connecting to the other computers running Win2k (via the uplink to the rest of the network) is fine. But XP to XP (connected to the same switch) is slow.
 
D

Dreamworld

Guest
#9
.. .and both machines are identical (same mobo, network card, settings etc. Fresh install of XP)

/Lars
 
G

greensteed

Guest
#10
I wondered what protocols you are running on each NIC. Mixing protocols can cause a speed problem I think as the protocols contend with each other. You using NWlink ?
 
D

Dreamworld

Guest
#11
TCP IP. Standard XP settings, haven't done anything. I do however wish there were settings to tweak as it's really annoying. It's faster to copy files to another (Win2k) computer and then from that to the other XP machine! I'm sure this is not what MS intended. I called MS (I supposedly get 2 free support calls), but they couldn't figure it out and said I had to call the "Pro-helpdesk" (and pay a fortune).. Me no happy.
 
B

BobTheBuilder

Guest
#13
Haven't got a solution but what if you move one XP to the other segment and try XP to XP now. Long time since I've heard the word but what about network collisions ? Could you have a high collision rate on the XP segment that is slowing things down ? Don't know how to check.
 
#14
I have the same problem

I am getting the same slowdown problem, but i know for a fact its a setting problem or something because before i reinstalled and formatted my pc, file transferring was working great, it was sooo fast, now its sooo slow.... the only difference i can piece out from my last config is that i am using NTFS and my bros is FAT32 (as supposed to FAT32 on both).... i dont think that has anything to do with it..... i didnt do anything different either, i followed the same procedure as usual when i re-install XP..... oh well, hopefully someone figures this out :( .....

RaZoR
 
#15
Works now!!!

ok i am transferring pretty fast now, around 2mb/s when i do some file sharing, its awesome.... i dont know exactly what did it but first if all i downloaded and installed the latest drivers for my network card, enabled 100MB FULL DUPLEX (under your netowrk card properties), and then i went to START->RUN->GPEDIT.MSC, then ADMINISTRATIVE TEMPLATES -> NETWORK-> QOS PACKET SCHEDULER and on the right panel i enabled LIMIT RESERVABLE BANDWITH to 0% (from 20%)..... but thats all i remember doing right now... i will re-post once i remember what else i did, hope this helps for now....

RaZoR

ps... sorry about double post but theres two threads about this subject....
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,014
Latest member
sanoravies