Serial Port/UPS Service

Discussion in 'General Hardware' started by GSR13, Oct 28, 2002.

  1. GSR13

    GSR13 Guest

    I am running Windows XP Home. Install was clean on a brand new HDD. I just purchased an APC UPS Backups Pro 1100. Comes with the PowerChute Software and Serial Cable.

    Hooked up the Serial Cable to my Serial Port (only have 1 serial port) and tried to use the WinXP UPS Service to monitor the UPS. Unfortunately, I get the following:

    "The UPS Service has lost communication with the UPS."

    In the Device Manager the Serial Port shows up without Conflicts. Port is set to COM1 / IRQ4. I have gone into the BIOS and changed Serial Port from AUTO to Enabled and verified Memory Settings and IRQ. Nothing. I have changed the Properties of the Port inside of XP to the minimum and it still will not work. I also updated my BIOS to the most current version available from DELL. I have removed the Port, disabled my internal Modem (COM3) and tried pretty much everything I can think of.

    I do have a PPC connected via USB. The ActiveSync settings were checked to use the Serial Port and a conflict did occur on bootup with ActiveSync. It was like ActiveSync knew the port was in use and I had to turn that option off in AS. I also hooked up my iPaq via the Serial Port and tried to use ActiveSync. It recognized a device was connected, but could sync.

    I get the impression that the port is working, but it is almost like it is only going one way. Like any BiDirectional Communication is not working.

    Sorry for the lengthy post, but I wanted to try and be as thorough as possible. Any help would be greatly appreciated.


    I would also like to add that I downloaded the most current software from APC's website and tried installing it. When it gets to the point of detecting the UPS the PowerChute software also fails.
  2. damnyank

    damnyank I WILL NOT FORGET 911

    Petal, Mississippi
  3. Zedric

    Zedric NTFS Guru Folding Team

    A shot in the dark as well. I heard (from my brother so it's not 100%) that XP won't allow you to access the ports directly like you would in earlier Windows versions (with IRQ and IO). So you would have to go through Windows API or something instead of direct access. Since you say the program wants the IRQ and IO of the port, it could be trying to access the port directly, which would be forbidden. I encountered this problem once in an accounting program that used the modem to dial to the bank. The old version tried to talk to the port directly. That didn't work. The newer version used the XP modem list to dial. That worked.

    Does anyone know if this is true? Correct me if I'm wrong.
  4. gonaads

    gonaads Beware the G-Man Political User Folding Team

    Did you go through the Control Panel > Power Options > UPS and set it up there?
    And did you select "Backup UPS Pro"???
    Also try switching between COM Ports.

    Also from the APC Web site, it says that for model BP 1100 (I think that's your model) Powerchute Business Edition V6.1 Software and Cable(s) 940-0020C (or 940-0095A) are the only ones compatible.

    It says:
    This document will tell you which version of APC shutdown software and cable is compatible with Windows XP and your specific UPS model.

    Also try this link to APC Support, step by step instructions on configuring native serial shutdown support in Windows XP:

    They say:
    Standalone computers in the Home/Home Office aren should follow this document to configure the Windows Native Shutdown support.
  5. GSR13

    GSR13 Guest

    Thanks for the help. Unfortunately, all the information provided has already been done.

    I am trying to use XP's built-in UPS Software. That is where I get the error. Thinking perhaps there was a problem, I downloaded PowerChute Business from APC and it could not find the UPS either.

    I have set up the COM port with all options as specified from APC and the Windows Knowledge Base Article listed above. Nothing works.

    Again, I have everything set up properly according to all MS and APC instructions. I am not sure if something I have installed is seizing the port and I do not know it or what.

    Zedric, sorry for the confusion. I did not mean that the application wanted to access the port via IRQ. I was simply saying that I had verified the BIOS settings and the Windows settings were the same. The "application" is the XP UPS tool under Power Options. I cannot imagine it having issues accessing the serial ports.
  6. gonaads

    gonaads Beware the G-Man Political User Folding Team

    In Device Manager, your COM Ports, what are they set at???

    Set your COM Ports like this (all of them):

  7. djmorgan

    djmorgan OSNN Addict

    I have a belkin UPS and had the same issue, what worked for me is switching off the XP ups and then loading the software that comes with the UPS re boot and it should find the serial.

    If you use both then they are both trying to access the port at the same time and this causes the prob.

    Still hope that helps.