• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Return to Castle Wolfenstein and OpenGL

J

JeremyT

Guest
#1
When I run RTCW I keep getting this error:

Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
...assuming '3dfxvgl' is a standalone driver
...initializing QGL
...WARNING: missing Glide installation, assuming no 3Dfx available
...shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
GLW_StartOpenGL() - could not load OpenGL subsystem


I have tried running it in different compatability modes to no avail. I ran the system info that came with it and it doesn't detect anything, ie.. cd-rom drive, monitor, my Riva TnT2, sound card etc... I have it installed on a partition seperate from the HD my XP installation is, but I don't know if this has anything to do with it.

My video drivers are the ones that came with XP because if I use Nvidias latest then XP won't even start...

Any help is much appreciated
-JeremyT
 

Howling Wolf

We did not deserve this !
#2
Did you tried the 23.11 dets, not the latests beta ones ? The game works great on a friend's puter with a Geforce 1st generation. He couldn't launch the game at the begining with XP native drivers: no OpenGL ! Updated to Nvid. 23.11 and it's ok, it works !
 
J

JeremyT

Guest
#3
When I use the 23.11 Detonators WinXP won't even start. I need to use the last working config to get XP to start up again. I've tried the 27.42 and WinXP will work fine with those (Haven't tried Wolf with them) but then D2:LoD won't work because it has trouble with Direct Draw. Maybe I could run that in a Win98 Compatibility mode though...

Our system specs are pretty similiar, I have:

WinXP pro; p3v4x MB, apollo pro 133a chipset; Riva TnT2 (with native XP drivers right now), pIII800; (2) 12 GB Seagate HD's,
 

Howling Wolf

We did not deserve this !
#4
JeremyT,
it may be an issue with the TNT2 video card, not especially yours... ?

Would you consider to upgrade your video, it is so much more fun with a recent card ! Look, since your not so old TNT2, we've seen GF1,2,3 and now GF4 each and every one in different flavor and boosted original specs !

I personally prefer ATI (RagePro3D, Rage128VO, Rage128ProViVo, and now RADEON 7500 (yes, I skipped a generation !), but it is my choice and doesn' add anyting to your problem, sorry !
 
J

JeremyT

Guest
#5
As much as I would love to have the $$$ for a new video card, it's just not gonna happen right now.. =( BUT, wolf SHOULD work just fine with my TNT2, it's just the quake3 engine and I've played that fine before albeit not on WinXP. If you do however want to send me one of your older but newer than mine ATI cards, send me an e-mail =) Thanks for the help though, someday it will work...

-JeremyT
 

Electronic Punk

willalwaysbewithyou
Staff member
Political User
#6
Hmm, sounds weird. Games definatly won't work properly with the default XP drivers as they don't have proper OpenGL support, try installing drivers for your motherboard whether it is sis or via, or something else I have forgotten!
 
E

eGoalter

Guest
#7
not in xp.

i dont think that riva tnt is gonna do very well in xp regardless, of what you do.i know its tough, but i would consider upgrading to geforce 2, 3 ect.. much better..but u could try the detonator,21.85
drivers they seem really good.;)
 

Electronic Punk

willalwaysbewithyou
Staff member
Political User
#8
I used to run Quake III and Unreal Tournament on a TNT
Dunno whether it would cope with the Team Arena engine tho, but those games were cool with it.
 
J

JeremyT

Guest
#9
All my other games will work just fine with the TnT. I get 60 FPS in UT at 1280x768. I haven't tried quake3 out yet, regardless, Wolf says it supports my card, it's either a WinXP problem or something is wrong with my openGL installation...

I can't see spending 100$ on an older Geforce2 when i'll just need to upgrade it again because it's too old. If I do get a new video card I'm gonna have to shell out the 350$ for a geforce4...

-JeremyT
 
E

eGoalter

Guest
#10
there ya go hehe.

u probably already checked this but im sure theres a patch for,rtcw, and opengl.u can try to run it in compatibilty mode as well.rtcw should be just great on xp, so try some diff drivers mabey u have default xp drivers installed? they donot support
open gl nor does , umm wait, i think im trippin does that tnt
use nvidia detonator drivers? incase it does ill post this link u can try some diff drivers. everthing from 21.85 and up adds support for open gl, and if tnt doesnt use detonator drivers u could try wicked gl or somthing, sorry i dont have a link to that. ahh ok they do use detonator. start with 21.85. i have never had a single crash or a game lock up on me with them, ofcourse im not using tnt though theres tons of em there, the latest 27.51 might be good for ya too.


http://www.3dnews.ru/download/drivers/nvidia/
 
Y

yorobbo

Guest
#11
anyone got any ideas how to get it to run on an ati rage 128 pro ultra agp, cos ive got the same problem as jeremy t and im all ot of ideas.
 
B

BENTLEY

Guest
#12
TIf you have a Via Chipset try to update your 4 in 1 driver
and reinstall Graphics driver. Nvidia needs the proper AGP support
from the motherboard to work

Worked for me


bentley
 

Members online

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,962
Messages
673,242
Members
89,017
Latest member
Seggar