Recovering Slackware partition

#1
Here's something I've been trying to figure out for two days now.

I had my laptop set up to dual boot XP Pro and Slackware 9.0. I had to re-install XP for some reason (Control Panel wouldn't load up, and nothing was able to fix it :mad: ), so in the process LILO was overwritten by the NT bootloader on the MBR.

I now need to find some way of getting into Slackware so that I can reinstall LILO, and get everything back to what it was.

Being a new Dell laptop, I don't have a floppy drive on this, so there are no boot floppies.

I have the Slackware 9.0 CD, but it's acting strange for some reason. When I boot from the CD, I get the "boot: " prompt where I usually just hit enter to load the bare.i kernel image that's located in the "kernels" folder on the CD. If I try hitting enter, I get the error "Cannot find kernel image: bare.i" I even tried entering "bare.i root=/dev/hda1 noinitrd ro" but I got a similar error.

I was thinking it could be a corrupt file on the CD, but I found that everything loads just fine when I boot from the CD on the other computer. So that's not the problem.

I really need to find some way of reinstalling the bootloader or at least some way of booting into my Slackware partition.

Anyone have any ideas...please! Thanks :(
 

j79zlr

Glaanies script monkey
Political User
#2
tsk, tsk, tsk, you gotta create a boot disk during the install :)

anyway, can't you use RAWRITE from DOS to create a boot disk, then reinstall LILO once you're in Slack?
 
#3
Yes, but I don't have a floppy drive on this laptop =\
...and it refuses to boot from the Slackware CD.

I'm burning a copy of Morphix (one of those LiveCD distros like Knoppix) to a rewritable CD. Might be able to boot from that and reinstall LILO ;)
 
#5
Problem Solved

No worries, j79zlr....I just got it fixed 5 minutes ago. I'm posting from Slackware right now. :)

Here's what I did. I first downloaded the Morphix live CD with the minimal components, so it was just a 200MB download. I then booted from that, exited X and got to the bash prompt. Then all I had to do was this:

Code:
cd /mnt
mkdir slack
mount -t ext3 /dev/hdc6 /mnt/slack
chroot /mnt/slack
/sbin/lilo
That was it! Just thought I'd post the solution here for future reference :D
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,970
Messages
673,297
Members
89,017
Latest member
Poseeut