• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Raid 0 Uh oh...

#1
Ok, I upgraded my main rig to dual 74GB Raptors, which was working fine until I tried to get my dual seagate 250GB drives which were in another machine as Raid 0 into the new rig. Well, the 74GB drives no longer work or are not detected when trying to boot, it says ntldr not detected. Anyway, that's not my biggest concern. The 2x250GB drives are non existant. They both were working fine in the other machine, but are not visible on the new machine. What gives?
 
#5
Actually, I was able to get Seatools and the Lifeguard tools to work. But I've run into another problem. The drives will not work together on the NVidia or onboard Silicon Image controllers. So I can only see one of my 250GB drives at a time.

So I went out and bought a CompUSA SATA controller which has the Silicon Image 3112 controller unlike my 3114 onboard. and hooked up my seagate 2x250GB drives on there, and my 1x250 WD drive to the Nvidia controller. Now the machine sees only 1 of the seagate 250GB and the 1 WD 250GB drive which I'm transfering the data from the WD to the Seagate right now, but the machine still can't see the other 250GB Seagate unless its' the only one on the SATA controller hooked up. Sooooo what I think I will do is once I transfer over the data from the WD to the one Seagate that is visible, I will then unplug the WD and hook up the 200GB IDE WD and the empty seagate drive and transfer the data from the WD to the Seagate. Once that is done, I will probably just hook up one Seagate to the new PCI controller, and the other Seagate to the Nvidia controller and leave it like that. IF that will work. If not, I'm running out of ideas.
 
#6
Slow down you lost me.

RAID 0 data is striped (split between the 2 drives). That means you can only see one drive even though 2 are connected. If the drives are striped (RAID 0) you can't get data off of one of them. Both have to be installed and recognized as a RAID 0 array to read them.

If you are reading data from one disk the drives were never in a real RAID 0 configuration.

Different RAID hardwrae controllers may not be compatible. Especially older ones. Data written to HD's on a silicon image may not be readable with an Nvidia controller. Contact their tech support.

Next question for tihe windows guru's is - Does WIndows XP support multiple RAID 0 arrays?

This may help:
http://12.24.47.40/display/2/index....512Q04X5i0UupP4SveI6dt2WJi7&cid=2&r=0.7322504
Western Digital jumpers must be set to single drive when used on SATA. A feature.
 
Last edited:

Luna

OSNN Senior Addict
#7
Did you move these drives from another controller? (i.e. were they in Raid 0 format on a different drive?)

If not, make sure your raptors are set to boot first on the Asus board. Since Asus offers both Nvidia and SI either should work. Don't forget to enable RAID for both drives in the BIOS and to create an array for them if you have not already. The default boot up key should be F10 for the Nvidia controller.

Keep in mind you can't split RAID over two controllers for a single array. It should be on the onboard Nvidia or the onboard SI.

I've run Raid 0 on two Asus SLI boards and it's been extremely easy to do.
 

Aprox

Moderator
Political User
#8
I have found the Nvidia RAID contoller to be nothing but trouble. You would probably be better off if you just disabled it in bios and use the Silicon Image controller instead. As LeeJend stated make sure both drives are connected, if its a RAID-0 then in windows or in the windows installer, only one drive will show up.
 
#9
Ok, well I've solved the issue with the raptors, those drives are already running in RAID 0 and blazing through things just fine. But my issues remain with the Seagate 250GB drives. They USE to be in a RAID 0 configuration on an ASROCK mobo before they were moved to this machine. So when I brought them over, that's when my issues started. Now, I've been able to format and delete the partitions on them, making them blank drives and being able to to be seen in Windows on their own. But one or the other cannot be seen together. So when they are both plugged in, only one is seen. I don't want them in RAID 0 anymore. I am just using them as storage drives on my main machine.

The Nvidia controller is the only one that has been working properly.
The SI controller hasn't even recognized anything. The drivers for that that I've used have been off of the ASUS site, as well as the drivers from the SI site. Right now I've been able to at least transfer the information that I want off of the old drives, and onto the Seagate drives. So I'm happy about that.
 

Luna

OSNN Senior Addict
#10
Make sure you have all your SATA ports enabled. On my Asus SLI system I have the option to disable certain ports or enable them for RAID. I can also enable or disable the Nvidia and SI controllers. If you are just trying to connect both drives as individually then you may need to make sure the ports you are connecting them to are not set up for RAID.

Are the Segate drives SATA or IDE? If IDE, be sure to check the jumpers.

If you have not, check for BIOS updates for your board as well. Asus is pretty good about keeping everything up to date. I have never tried SI Raid but Nvidia Raid works very well for me on my Asus board (I've got two 36gb raptors in raid 0)
 

Members online

No members online now.

Latest posts

Latest profile posts

Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,015
Latest member
evaiwhitis