• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Possible Fowarding port issue??

zapoqx

Striking Master
#1
Hey all, I'm back with another question...
I'm trying to get TeamSpeak 2 RC 3 and Server to work correctly. I can get the Teamspeak client to run and run well. TeamSpeak Server doesn't run correctly. I can get it to run if I have my client connect to my computer's IP but I can't get it to connect to my internet IP to connect with me. I've tried alot of stuff but can't think of anything else. I know I need to foward port 8767 to my system.
When I do get it to work, I can only hold it open for like 10 minutes than the server can't be found again but the server is on. Only twice so far have I been able to make it last for as long as I've had the server on but can't figure out how. Any suggestions? Thanks
P.S. yes, I'm using a Router.
 

kcnychief

█▄█ ▀█▄ █
Political User
#2
zapoqx said:
Hey all, I'm back with another question...
I'm trying to get TeamSpeak 2 RC 3 and Server to work correctly. I can get the Teamspeak client to run and run well. TeamSpeak Server doesn't run correctly. I can get it to run if I have my client connect to my computer's IP but I can't get it to connect to my internet IP to connect with me. I've tried alot of stuff but can't think of anything else. I know I need to foward port 8767 to my system.
When I do get it to work, I can only hold it open for like 10 minutes than the server can't be found again but the server is on. Only twice so far have I been able to make it last for as long as I've had the server on but can't figure out how. Any suggestions? Thanks
P.S. yes, I'm using a Router.
Well, while your problem is well stated, some of the variables are sort of vague. However, I will give it a shot.

If you are doing ANYTHING with port forwarding, it is best to be done on the router. Are you setting up TCP, UDP or both? Did you set your server to have a Static IP? Do you have a software firewall in place on the Server, perhaps Windows XP SP2?

More information please :)
 

zapoqx

Striking Master
#3
Well from the help file, it says that it needs UDP 8767 so in the router settings, I have the following:
  • Special Applications
    • Trigger Port: 8767
    • Trigger Type: UDP
    • Public Port: 8767
    • Public Type: UDP
    • Enabled
  • Port Fowarding
    • Server IP: 192.168.XXX.XX (Censoring)
    • Mapping Ports: 8767, 1717, 1716, 20045, 2300-2400, 6073, 80
      • I have all those ports opened because of various other programs.
    • Enabled
  • Virtual Server
    • Number: 1
    • Private IP: 192.168.XXX.XX (again, censoring)
    • Private Port: 8767
    • Type: UDP
    • Public Port: 8767
    • Enabled
  • DMZ Server
    • Public IP: 0.0.0.0 (Can't change it for some reason even if I wanted to)
    • Private IP: 192.168.XXX.XX (Again censoring)
    • Disabled
      • I used to have this on until i learned more of the other parts, but the server never properly worked with it on.
As for my connection...
I use Earthlink High Speed Cable.
Now I am not sure if I use Dynamic or Static IP because:
  1. We were never told what our IP and information was. I found out myself.
  2. I had an IP that ended with .4 and a couple of weeks back, lightning hit our cable or something in which all of the cable in the Apartment Complexes had to reset. When it was reset, the IP changed to .9
I do know the information to put in the Static IP from the looks of the router, but I don't know, you tell me. Would mine be considered Dynamic IP or Static IP?

And anyway, I use ZoneAlarm. Unless there is a setting that I need to fix, I had it work before with ZoneAlarm on when I was connected directly to the Cable. The Teamspeak Server always finds the IP of my computer and never the internet IP (thought that would be important to add).

Also, it might be important to add as well that my Earthlink Total Access account used to find the internet IP easily before the IP change from .4 to .9 (the only thing that I changed before the incident of the cable going out) which worked fine was changing the 3rd part of the IP address from the regular .2.1 to something else. Thanks
 

American Zombie

Administrator
Staff member
Political User
#4
zapoqx said:
And anyway, I use ZoneAlarm. Unless there is a setting that I need to fix, I had it work before with ZoneAlarm on when I was connected directly to the Cable. The Teamspeak Server always finds the IP of my computer and never the internet IP (thought that would be important to add).
Don't need ZA if using the routers firewall.
 

kcnychief

█▄█ ▀█▄ █
Political User
#5
zapoqx said:
Well from the help file, it says that it needs UDP 8767 so in the router settings, I have the following:
  • Special Applications
    • Trigger Port: 8767
    • Trigger Type: UDP
    • Public Port: 8767
    • Public Type: UDP
    • Enabled
  • Port Fowarding
    • Server IP: 192.168.XXX.XX (Censoring)
    • Mapping Ports: 8767, 1717, 1716, 20045, 2300-2400, 6073, 80
      • I have all those ports opened because of various other programs.
    • Enabled
  • Virtual Server
    • Number: 1
    • Private IP: 192.168.XXX.XX (again, censoring)
    • Private Port: 8767
    • Type: UDP
    • Public Port: 8767
    • Enabled
  • DMZ Server
    • Public IP: 0.0.0.0 (Can't change it for some reason even if I wanted to)
    • Private IP: 192.168.XXX.XX (Again censoring)
    • Disabled
      • I used to have this on until i learned more of the other parts, but the server never properly worked with it on.
As for my connection...
I use Earthlink High Speed Cable.
Now I am not sure if I use Dynamic or Static IP because:
  1. We were never told what our IP and information was. I found out myself.
  2. I had an IP that ended with .4 and a couple of weeks back, lightning hit our cable or something in which all of the cable in the Apartment Complexes had to reset. When it was reset, the IP changed to .9
I do know the information to put in the Static IP from the looks of the router, but I don't know, you tell me. Would mine be considered Dynamic IP or Static IP?

And anyway, I use ZoneAlarm. Unless there is a setting that I need to fix, I had it work before with ZoneAlarm on when I was connected directly to the Cable. The Teamspeak Server always finds the IP of my computer and never the internet IP (thought that would be important to add).

Also, it might be important to add as well that my Earthlink Total Access account used to find the internet IP easily before the IP change from .4 to .9 (the only thing that I changed before the incident of the cable going out) which worked fine was changing the 3rd part of the IP address from the regular .2.1 to something else. Thanks
First off, you have Dynamic IP on the outside, but I was referring to a Static IP on the Workstation you are forwarding the port to. The machine you are forwarding port 8767 should have a Static IP.

You don't need ZoneAlarm, and that definitely could be causing problems. You could still use it however, but you would have to write internal rules for that program, and that depends on your version. If you are using the free version, it's a pain to enable rules properly.
 

zapoqx

Striking Master
#6
Ah, I got it working. The Static IP is what I gave my system from my MAC address in the router. So yes, it does have Static IP. I am using ZoneAlarm Pro. Never understood how to do those expert mode stuff. And it is working with Zone Alarm off. Also, I think it was a torrent program that I had running because I tested it and it didn't work correctly.
 

j79zlr

Glaanies script monkey
Political User
#7
FYI, you do not have to sensor LAN IP addresses, it is not a security risk. Really revealing your WAN IP isn't a security risk either, its easy enough to get.
 

Members online

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,012
Latest member
Sierge