• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Networking WinXP & Win2k

ziptrx

OSNN Addict
#1
I am having trouble networking a WinXP machine and a Win2k machine. Both have the same workgroup name and are connected through a router. The XP system sees the Win2k, but can not access it, while the Win2k can't see the WinXP. This just started after I ran the network wizard on WinXP. Before, both systems could see each other, but couldn't access due to requesting login information that I never setup. What am I doing wrong? Any help is greatly apprectiated.
 

j79zlr

Glaanies script monkey
Political User
#2
As long as you are using XP Pro, disable simple file sharing, and make sure both PC's have the same usernames with passwords.
 

ziptrx

OSNN Addict
#3
Same username and password? The Win2k machine is my neighbor's, so having the same isn't possible to do. I'm trying to pull his documents off my machine onto his without having to use a cd. Is there a way that his machine can just access mine without having mine see his or vice versa?
 

ThePatriot

-=[BOHICA!]=-
Political User
#5
You could just create a temporary account on each machine for this, and delete the accounts when done. I assume this will only be a temporary thing, corrct?
 

ziptrx

OSNN Addict
#6
ThePatriot said:
You could just create a temporary account on each machine for this, and delete the accounts when done. I assume this will only be a temporary thing, corrct?
Yeah just temp. I'll do as you suggest. So make an account on each computer with the same account name ie tempuser as the name on each and workgroup as the group name?
 

j79zlr

Glaanies script monkey
Political User
#7
workgroup doesn't make a difference, as far as I know you must use usernames and passwords when working with XP and 2k, if they were both XP then you could use simple filesharing [but I don't recommend it], I don't think that is an option with 2k.
 
P

PseudoKiller

Guest
#8
you need to have a username and a password. You can not assign shares without a password. He could connect to the machine by IP or by machine name and fill in the username and password or you could (if running windows xp pro) create and ftp connection and allow him to connect that way. Up to you.
 
#9
All suggestions are not working. :( Tried using an ftp program, but kept timing out. Who knows what is causing the problem. Oh well, I'll keep trying. Thanks for the help.
 

ThePatriot

-=[BOHICA!]=-
Political User
#10
Just poking at stuff here...both nic's show up ok in Dev Mgr? Both connections are enabled in Network Places?(i've seen these mysteriously disable on their own). You are going pc to router, so you are using a patch cable vs a crossover? Forgive me if I'm being repetative.
 

Reg

eXperienced!
#11
You need to first establish the the fact that you can "see" your neighbors computer. If you are connecting via the Internet, you'll need to make sure that you can connect to that computer (try pinging the IP). Second, make sure that there are no firewalls blocking the connections (i.e. software, router, etc). Finally, you will need your neighbor to create an account on his machine and give that account access to a shared file/folder.
 
P

PseudoKiller

Guest
#12
ok ok ok .... when all else fails there is the n00b way of doing things. :D

Option 1: Get a gmail account and email the files to his email addy

Option 2: Do you have some web space?? then upload the files and link to them so he can download them to his machine.

:D
 

Steevo

Spammer representing.
Political User
#13
My friends can dial in to my PC and use my internet, and or network.

If you are using a cable-broadband modem, most have been setup with no ports open, and no port forwarding. Just to keep people from running websites.

There are hundreds of different ways to do this, but the easiest will still be the CDR. Why is this a problem?
 

dadecamp

under worked, over paid
#14
You need to be part of the same workgroup. If you haven't yet, run the network wizard on the XP machine to create the workgroup. Then take your XP disk to the Win2000 machine. When it autostarts choose the "additional stuff" (or whatever it says) then network wizard. You can then run the network wizard on it. Make sure they both end up with the same workgroup. I think it will be MSHOME.

You should then be able to go to the Network Places and click on Workgroup Computers on the side bar menu. It may take a few seconds but you should be able to see both computers in the window. Clicking on his computer from yours you should see only the "shared" folders on his computer. He should only be able to see you "shared" folders from his computer.

As far as the user id and passwords, you don't need the same account on both computers, you only need to be in the same workgroup. At least that is how I ran my home network with the win2000 being the server/gateway and XP on several PC's and notebooks throuout the house, each with their own passwords and user id's.
 

dadecamp

under worked, over paid
#15
After re-reading your original post I must ask if you have the files you want to move in a "shared" folder or any "shared" folder?? If they are not "shared" nobody can see them. ;)
 
#16
The "same user and pass" is an ugly hack that, IMHO, shouldn't be used. You can share files without using the same user name and password, you'll just have to type in a correct user and pass when you access the shared folder. If the computers don't even see eachother it's is another problem.
 
#17
Oh, since it's your neightbour, if you're going across a public network you should never use windows file sharing. It's pretty much suicide. FTP would be better.
ziptrx said:
All suggestions are not working. :( Tried using an ftp program, but kept timing out. Who knows what is causing the problem. Oh well, I'll keep trying. Thanks for the help.
If the server has a router, then that's the problem. You'll need to forward ports for passive mode (PASV) in order to get it to work. But then again, if you have a router (or firewall for that matter) then file sharing shouldn't work either...

Another tip for temporary file transfer is YouSendIt: http://www.yousendit.com/
 

Howling Wolf

We did not deserve this !
#18
I agree to that, not the same user/password, but create an account existing on the other computer and give him the desired rights.
You could also (after adding 2 network cards), set a static ip on both, ie. : 192.168.120.1 and 192.168.120.2, with same workgroup of course and shared folder(s), they should see one another. You'll have a dedicated network connexion for this purpose.
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,018
Latest member
dixoncarry