Network Card & Windows XP Please Help

B

bender7542

Guest
Just purchased a new computer with windows xp and was trying to use the network card from the old computer. I put in the card and get the following message upon bootup after the card is recognized.

Cannot Install This Hardware

Ethernet Controller

An error occured during the installation of this device

The data is invalid.

I have tried the following cards and get the same result each time. (I believe that all of these will work in XP)

Dlink DFE-530TX+
GFC1216C-TX-50
Netgear FA311

I have tried different slots and I have tried to manually add the drivers and still get the same results.


I have searched the internet for the problem and came across a few others who had this problem but never was a solution posted.

My system is as follows:
Processor: Pentium 4 1.7 Ghz
Memory: 512 Mb
Video Card: Winfast Geforce2 MX (64 Mb)
Sound Card: Microsoft Kernal DRM Audio Descrambler
Operating System: Windows XP

Both the Dlink and the Netgear drivers for XP are on the XP CD and I have tried to manually install using those drivers and still get the same message.

What am I missing? I have put each of the cards back in the old computer (Windows ME) and they work fine.

Thanks for any insight anyone can provide.
 

Bootsy

Huh?
Joined
20 Feb 2004
Messages
1,124
I have bad news for you. I had the same problem and even called MS because no matter what NIC card I used it was still invalid data when the drivers were being installed. By the way, Microsoft didn't know what the problem was either...go figure. Anyway, the only was to fix this problem Im afraid is to re-install windoze...thats what worked for me.
 
B

bender7542

Guest
Which reinstallation did you do? I was given two options
 
S

sjf99

Guest
I had the same problem with my ABIT TH7II-RAID based system. I did an install of XP with just the video card as per the abit XP FAQ. When I went to add the NIC, I got the 'Data in invalid' msg. I left the NIC in and did a fresh install (reformatted the HD). The NIC then worked. I then went to add a new SB Audigy and got the same msg. I did another fresh install (no reformat this time). It now seems to work.

But what is causing this? I'd hate to have this system running for months and want to add new hardware only to have to re-install.

System Info:
Abit TH7II-RAID MB
P4 1.8 (478 pin)
512 Meg RAMBUS
Leadtek GF3 Ti200 TDH
Intel Pro 100 S NIC
Sound Blaster Audigy Gamer
2 Raid arrays (2 20 gig C: drive mirrored & 2 60 gig D: drive Striped)
IDE CD Rom
MS Intellisync Explorer Mouse
HP Keyboard

Any ideas?

Steve
 
A

Augie66

Guest
I'm sorry that I do not have an answer but a question. Which version and release of XP are you using?
 
B

bender7542

Guest
Ended up reformatting the hardrive and everything works fine now.
 
S

sjf99

Guest
I'm running 5.1 build 2600.xpclient.010817-1148. It's from the MSDN developer's kit. I assume it's the same as the retail version.
 
E

experts

Guest
THE SOLUTION!

digitalKnowHow.com to the rescue!

Ok, if you are getting a "Data is invalid" error when installing drivers here's what is probably going on and how to fix it:

There is an issue that sometimes occurs while installing drivers for add-in cards (such as SCSI controllers and audio cards). Basically the Windows registry automatically records SOME info on the device but brands the info as 'read only' and will not allow the driver install to properly complete, giving the cryptic "Data is invalid" error. This can happen under both Win2000 and WinXP. To fix it, you'll need to manually edit your registry. This easy to do but if you're not comfortable doing it go grab the geekiest friend you have and watch and learn while they do it for you (make sure to back it up, first!).

Here's the solution:
Go to START, then RUN, and type "REGEDT32" (not "REGEDIT"). In the REGEDT32 program, find the window titled "HKEY_LOCAL_MACHINE" and maximize it. Open the following folders by double-clicking on them:

SYSTEM\CurrentControlSet\ENUM\PCI

You will see a lot of folders ('keys', in this case) named "VEN_xxxxxxx..." where "xxxxxx" are strings like "1102&DEV_0004&SUBSYS_00011103&REV_04". Inside each of these folders will be a folder(s) with a long numerical name. Click on each folder and look for an entry named "DeviceDesc" that has a description containing the name of the device you are having trouble installing. When you find the correct folder, click "SECURITY" then "PERMISSIONS" from the REGEDT32 menu bar. In the window that opens select "ALLOW" next to the "Full Control" option. Close REGEDT32 and reinstall your drivers - they should install just fine, now.


Send any messages of thanks (and any monetary rewards you feel like contributing) to "experts@digitalKnowHow.com". If your geeky friend hoses your system it's entirely his fault - not ours.

Happy installing!
-digitalKnowHow.com:D
 
S

seestyle

Guest
I have been having the same problem, is re-formatting the only option? I suppose there is no point in calling MS.
 

Members online

No members online now.

Latest profile posts

Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.
Terrahertz wrote on Electronic Punk's profile.
Yo fellas!
Electronic Punk wrote on Sazar's profile.
Where are you buddy?
Perris Calderon wrote on Electronic Punk's profile.
Hey EP! All good with me, applying for Microsoft MVP right now, should have done this a while ago.

Notifications don't work, I only found your response by coming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier!
Perris Calderon wrote on Electronic Punk's profile.
EP, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there!

Forum statistics

Threads
61,997
Messages
673,411
Members
5,589
Latest member
EmilyFox