Need Help with Critical WinXP Problem


Rob Snoozer


I have been using WinXP Pro for 4 months now - with no problems. Yesterday - during a reboot I got this error:
ISASS.exe - Endpoint Format is Invalid -- and the sytem rebooted.

I tried to recover via Recovery Console - no errors from chkdsk - and a roll back of the registry hive using WinRescue XP, etc... also didn't work.

I then made a critical mistake and contacted MS Support and after an interminable wait - I was advised to to a Repair Reinstall.

I ran setup and did the repair - and during the first setup reboot - I got the BSOD with the following error message --- NO_MORE_IRP_STACK_LOCATIONS 0x00000035, and the system would reboot. I have not gotten past this screen. I haven't been able to find any other reference anywhere to this problem in windows xp installs.

There were a number of suggestions to resolve the problem - and I did all of them.

I went to bios - checked all settings - dropped RAM from 768 to 256 - removed all unnecessary peripherals, installed a basic AGP video card, changed all the BIOS entries (RAM speed to 100 from 133, remove all Ram shadowing etc) ... and tried again. Still no success...

Finally - I decided to install Windows XP on my D drive - (20gb). It installed without problem.

This of course suggests a hard disk drive problem. But none is apparent... I can access all files on the C (which is a 60 gig drive) ... I have used several hard disk drive diagnostic utilities (microscope, SANDRA, etc) and the C drive is fine.

I then tried to make a backup (dumb move - I've been up all night) and reinstall from the backup - no luck. The backup now has the partially completed install. I have a backup of my critical data - but I am not sure how to proceed.

I don't see how to get past this problem ... I don't want to lose the system as it is setup - and I don't have the time at the moment to completely reinstall all my software ...

When you reinstall windows xp over another copy of windows - it deletes all the files in the windows directory - (I did this once before in late November with WinXp and had to reinstall all the software.)

Any suggestions?

rob snoozer


OSNN Veteran Addict
The only mention I can find of the irp error is in relation to a mouse causing it? which seems really odd. So i'm not sure how to process since you can't even login to the part to do a system file check /scannow

I'll look around some more and ask anyone at work if they've heard of it, but right now i'm betting you might have to start off clean :(


I had the same BSOD. This BSOD is sometimes caused by a faulty driver. In my case it was the driver for the CD-rom unit.

I tracked the problem by disconnecting unit after unit until the computer booted normally. When I disconnected the CD-rom it booted normally. When I connected it I got the NO_MORE_IRP_STACK_LOCATIONS.

When you find what unit is causing the problem, you have to find the driver causing the problem in ..\system32\drivers. In my case it was a NT4 driver that by mistake was present in the folder.

You can read more about the BSOD NO_MORE_IRP_STACK_LOCATIONS on

You can also search the Internet with a search engine to find more hints.

Rob Snoozer

Thanks both of you for your comments and suggestions.

It makes sense that there is a faulty driver at work - as I have been able to install xp onto another drive.

What puzzles me is this - I have done absolutely nothing to the system since my November install - with the single exception of Microsoft's own patches to XP...

Hmmm ... is it possible that windows xp loaded one of these files instead of the fresh files from the installation disk?

Thanks again.

Rob Snoozer


That is possible. I have received erroneous files from Microsoft. Compare the drivers in ..\system32\drivers in your system with the drivers of a freshly installed XP.

Rob Snoozer

Thanks for your help. I tracked the problem down to video driver for my Hercules 3d Prophet - downloaded from the Windows updates.

I am now able to get back into windows in safe mode - but am plagued with the original problem

ISASS.exe - Endpoint format is invalid ...

I will try to do a repair installation to try and rectify this problem.

Thanks again,

Rob Snoozer

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member