• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Moved onto Another Linux Desktop

Heeter

Overclocked Like A Mother
#1
Hey All,

In case some of you missed the other linux thread I had going about my PClinuxOS box not wanting to access Windows shared folders, I have moved on to another OS.

First, downloaded Ubuntu desktop 7.10. burned image and and tried install it, the screen would go blank after the Ubuntu progress bar would reach the end. I said okay, it might not like my X800XL vid card (which I found strange, but anyways), so I took apart the case and replaced the X800XL with and older ATI9250. I restarted the process, screen went blank at the exact same time in the process. Okay now what, I said, it doesn't like my 9250????? So I took apart the case again, and this time I installed my really old Gforce2MX vid card. restarted the process several times, still same thing. I went back to my other machine and downloaded "Kubuntu" KDE version of Ubuntu, and tried it. Same thing happened. I also tried graphics safe mode, and text mode to no avail. I have come to understand that Ubuntu doesn't like my monitor.

Oh well, slightly frustrated, I went to my other machine and went to a linux site to see what other full desktop distros are available. I found Fedora8. I downloaded the dvd (yahoo!!! it allowed me to use my download manager flashget, and I got the 4gig iso downloaded in 31 minutes!)

I have installed Fedora8, selected the gnome desktop ( I had a choice) and once installed, I was able to easily pull up my Windows shared drives, and put shortcuts on the desktop, no problem.

Now upon reboot, I have a new friggin issue, the dammed gnome keyring is locked and I have to manually input a password (which is the same as the user/pass) to unlock and to let the shortcuts open.

This friggin crap never friggin ends.................................


Heeter
 

j79zlr

Glaanies script monkey
Political User
#2
That's standard if you are using samba. You can however mount the remote file systems to a local mount point using fstab.

//server/share /localmount/share1 smbfs userid=foo,passwd=bar,rw 0 0

I believe support for samba files shares are default in the fedora kernel.
 

Heeter

Overclocked Like A Mother
#3
Awesome thanks, J

Ya pull through again...... Can't wait to try it.

I have tried the other fixes that I've googled, like updated a PAM module, and modded a gdm file until it looks like a 500 page essay.

Can't wait to try your setup.


Thanks,


Heeter
 

j79zlr

Glaanies script monkey
Political User
#4
That is OK for a home setup, but remember that /etc/fstab is a cleartext file and leaves your username and password easily available to anyone in the network.
 

Dark Atheist

Moderator
Staff member
Political User
#5
i did say that the ubuntu installer can be a tit at times and it was best to select text installer ;)

http://www.justlinux.com/nhf/Filesystems/Mounting_smbfs_Shares_Permanently.html

Providing Security

The /etc/fstab is readable by everyone so it obviously wouldn't be a good idea to have your Windows password in it. The way to get around this is by using what is known as a credentials file. This is a file that contains just the username and password. The best place to put this file would be in your home directory. Here is how to do it.
Create a file in your home directory named .smbpasswd (the period at the start of the filename makes it a hidden file). Modifify the permissions on the file so only you have permission to read and write to it. The only thing in the file is your Windows username and password. Here's the commands you would enter to create the credentials file:
cd echo username=mywindowsusername > .smbpasswd echo password=mywindowspassword >> .smbpasswd chmod 600 .smbpasswd Substitute your Windows username and password in the commands. No one else except root would be able to read the contents of this file.
 

Heeter

Overclocked Like A Mother
#7
Hi Guys,

Sorry took so long to respond.

I am trying to get past the keyring. The samba part is working fine, right out of the box.

I have tried the fstab and the other one from Carpo, but the keyring is still locking up upon reboot.


Thanks,


Heeter
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,013
Latest member
Pdawgintown