IRQ problem after graphics card install

Tuffgong4

The Donger Need Food!!!!
Political Access
Joined
21 Jun 2002
Messages
2,465
I installed a new graphics card in my desktop and now I am unable to open any of my usb storage drives...(flash drives, sd cards)...

I'm assuming this has to do with my irq settings but I don't know how to fix this...see sig for hardware and OS.
 

dreamliner77

The Analog Kid
Joined
16 Mar 2002
Messages
4,714
I assuming that this is not an add-in USB PCI card (if it is, move the card). Probably the easiest thing to do is uninstall the USB hubs from Device Manager, reboot and Windows re-install the devices.
 

Tuffgong4

The Donger Need Food!!!!
Political Access
Joined
21 Jun 2002
Messages
2,465
No, it was an upgrade from a 7600GT to a 9800GT. The problems started then. I don't have a hub, but I might be able to uninstall everything that is usb related and reinstall...Something doesn't add up, I've never had a problem with anything vista related. I remember having a problem like this in XP...but can't remember the fix.

What I'm not excited about is maybe having to go through the registry to get rid of usb drives...
 

Tuffgong4

The Donger Need Food!!!!
Political Access
Joined
21 Jun 2002
Messages
2,465
update. If I go into my device manager and uninstall a usb2 host controller labled 283A when it reinstall it works. I'm not sure if that helps anyone with diagnosing my problem but I thought I'd throw that out there...

Also is there a way to look in the registry and know what is what when it comes to usb devices. I'm guessing if I uninstall some of those it might work.
 

dreamliner77

The Analog Kid
Joined
16 Mar 2002
Messages
4,714
Glad you got it. just and FYI, I didn't mean an actual physical hub but Device Manager picks up USB "hubs."
 

Tuffgong4

The Donger Need Food!!!!
Political Access
Joined
21 Jun 2002
Messages
2,465
well it isn't technically fixed since I have to clear out the same hub in the device manager everytime I want to use it.
 

lancer

There is no answer!
Political Access
Joined
7 Oct 2004
Messages
3,093
hey tuffgong, not sure if this is really a solution, but if i ran into this problem, this is what i would do, uninstall the nvidia card and all drivers from the machine. going so far as to make sure none where in system32.

I would then uninstall all the usb drivers hubs, anything to do with the usb ports.

i would restart the comp go into bios, and first try putting all settings to default, at the same time i would look into the irq settings there, you may be able to assign the v/card and usb ports to separate irqs.

Thats what i would do, not sure if it would do anything.

if that does not work i would do the same again but disable the usb ports completely after uninstalling them, reinstall the v/card and then install the usb ports again and hope the os assigns the irqs correctly.
 

Tuffgong4

The Donger Need Food!!!!
Political Access
Joined
21 Jun 2002
Messages
2,465
the thing I haven't done is assign manual irq settings in the bios. also I haven't tried uninstalling everything. Later today I will try both of these and pop back with progress.

The weirdest thing is the hardware gets installed but doesn't get assigned a drive letter.
 

Tuffgong4

The Donger Need Food!!!!
Political Access
Joined
21 Jun 2002
Messages
2,465
I can't uninstall all of the drives without losing my keyboard and mouse, I feel like a damn fool. I can usually fix stuff like this no problem, my memory card reader and certain usb flash drives just don't show up, well they show up but don't get assigned drive letters.

gotta be something to fix this.
 

Dark Atheist

OSNN Veteran Addict
Political Access
Joined
8 Apr 2003
Messages
6,376
check in the bios and make sre plug and play os is set to yes, or select no and manually assign irqs, another thing you could do is disable the other usb ports you dont use in the bios, i only require 4 at most, but at defualt 10 are on, turning off the other usb ports might help
 

LordOfLA

Godlike!
Joined
2 Feb 2004
Messages
7,026
make sure "assign irq to vga" is disabled in the bios. It doesn't need one these days.

Also if you have ACPI turned on IRQ's are irrelevant. The PIC will resolve IRQ issues for you. The problem lies elsewhere.
 

American Zombie

Moderator
Staff member
Political Access
Joined
23 Jun 2004
Messages
2,961
check in the bios and make sre plug and play os is set to yes

Unless it is a very old motherboard you do not want to set PNP OS to yes as ACPI will take care of IRQ's. Like Lord suggested, make sure ACPI is turned on and/or APIC if the board supports it. Although you usually have to turn on APIC before installing the OS.
 

Tuffgong4

The Donger Need Food!!!!
Political Access
Joined
21 Jun 2002
Messages
2,465
sadly i got the low end of the stick when I purchased my motherboard, and there aren't that many settings for things like this. I'm digging deeper in the bios later and will post back.

Thanks Everyone for the suggestions, I'll post back with results.
 

Members online

No members online now.

Latest profile posts

Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.
Terrahertz wrote on Electronic Punk's profile.
Yo fellas!
Electronic Punk wrote on Sazar's profile.
Where are you buddy?
Perris Calderon wrote on Electronic Punk's profile.
Hey EP! All good with me, applying for Microsoft MVP right now, should have done this a while ago.

Notifications don't work, I only found your response by coming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier!
Perris Calderon wrote on Electronic Punk's profile.
EP, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there!

Forum statistics

Threads
61,997
Messages
673,411
Members
5,591
Latest member
nodee