• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Irp Stacks???



Help, AGAIN!!

I set up my computer with a new motherboard , Soyo Ultra Kt333 with Corsair DDR333 512mb of RAM and several new WD 80Gb HDD w/ 8mb of cache. I installed Windows XP home and updated to SP1 and the BOX ROCKS except....

When I try to power up my Firewire external HDD (after the computer is running) or plug in a USB Thumbdrive, I get a blue screen stop error (No_More_IRP_Stacks_Available)

I've tweaked the BIOS settings, checked for resource conflicts and nothing seems to help.

Any ideas?
I did a search on the Microsoft Knowledge Base on "IRP" and found that this stands for 'Input/Output Request packets' and is used by WDM (Windows Driver Model).

I think that you have an outdated driver installed - probably from SP1. Try to re-install the drivers for the HDD and the Thumbdrive.

I hope this helps.


Dear SysProg,

I tried to uninstall the firewire and HDD and reload the drivers but no go, sam problem.

The USM thumbdrives do not require drivers as they are automatically recongnized as removeable drives in Operating systems newer that Windows 95. The Friewire drive works great as long as it is powered up before I boot the computer but if I turn it on after the box is booted then I get the blue screen.
I'm sorry but I then have no ideas on the Firewire problem.

I had a similar problem with a USB scanner not being recognized if it was not powered up prior to XP starting or when you tried to use it an hour or so after booting XP. I resolved the problem by turing off the power saving mode on the USB hub in Device Manager.

I'm not at home with my XP system so the following procedure is being done from memory.
- right click My Computer and select Properties.
- click the Hardware tab at the top of the dialog box.
- click the Device Manager button (on the right side of the dialog box about 1/2 way down.
- click the '+' sign by the Universal Serial Bus controllers line.
- right click on each of the items that expand and select Properties. Look around for Power Saving features and disable it. (This is where my memory is foggy as I did this 4-5 months ago).

Search the forums for 'Power saving', 'USB', or 'Scanner'.

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member