• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

I can only get a few parts of Active Desktop working

P

PC-Dude

Guest
#1
I got the run command to open and Solitaire opens fine however any other program i do won't work. Click on it and nothing happens. I must be a total moron I guess :(
 

Bman

OSNN Veteran Original
#2
no no, your not, i did them but every one i make to open a program, it opens sol instead of the program i want! So your not dum!
 
P

PC-Dude

Guest
#3
Damn I was looking forward to this being setup ...oh well guess i'll have to stick with the desktop shortcuts for programs. :eek:
 

madmatt

Bow Down to the King
Political User
#5
No.

XP does not have to be installed on the C_DRIVE for it to work. However, you need to follow the steps in the tutorial to a tee.

If you can get SOL to work, then you can get any program to work. You just need to follow it step for step.

You need to create a NEW shortcut. Place it in the \WINDOWS\ directory. Name the shortcut WITHOUT spaces in its name.

Then create the .VBS file and place the shortcut name in line three (where specified). Place this file in \WINDOWS\ also.

Create your A HREF tag with the .VBS file being called from the EXEC() command.
 
P

PC-Dude

Guest
#6
Ok I made a shortcut to MIRC in the windows dir the way the tutorial said, then I created the .vbs file below:

Dim oShell
Set oShell = WScript.CreateObject ("WScript.shell")
oShell.run "mirc"
Set oShell = Nothing

Then I added the link to the .html doc like so:

<HTML>
<HEAD>
<TITLE>Active Desktop</TITLE>

<script>
function exec (command) {
if (document.layers && navigator.javaEnabled()) {
window._command = command;
window.oldOnError = window.onerror;
window.onerror = function (err) {
if (err.indexOf ("User didn't grant") != -1) {
alert('command execution of ' + window._command +
' disallowed by user.');
return true;
}
else return false;
}
netscape.security.PrivilegeManager.enablePrivilege
('UniversalExecAccess');
java.lang.Runtime.getRuntime().exec(command);
window.onerror = window.oldOnError;
}
else if (document.all) {
window.oldOnError = window.onerror;
window._command = command;
window.onerror = function (err) {
if (err.indexOf('utomation') != -1) {
alert('command execution of ' + window._command +
' disallowed by user.');
return true;
}
else return false;
};
var wsh = new ActiveXObject('WScript.Shell');
if (wsh)
wsh.Run(command);
window.onerror = window.oldOnError;
}
}
</script>

</HEAD>
<BODY BGCOLOR="#FFFFFF">


<a onClick="exec('run.vbs'); return false;" href="java script:void(0)">Run Command</a>

<br>

<a onClick="exec('mirc.vbs'); return false;" href="java script:void(0)">Launch MIRC</a>

</BODY>
</HTML>

Still No Go, the run command works and the sol worked(I have removed it now)
Does this look right?
 

djwhite

OSNN Senior Addict
#9
try changing this:
if (err.indexOf('utomation') != -1) {
to this:
if (err.indexOf('automation') != -1) {

That's the only thing different to mine
 
P

PC-Dude

Guest
#10
Originally posted by djwhite
try changing this:
if (err.indexOf('utomation') != -1) {
to this:
if (err.indexOf('automation') != -1) {

That's the only thing different to mine
Thanks for you help, but even after I changed that still no go, hmmmm i don't know what i'm doing wrong here, i'm following step by step, I have no antivirus running or a firewall so that's not the problem.

Ohh well i'll try a bit later and if it still don't work, i'll have to give up on it.
 
P

PC-Dude

Guest
#12
Some more info, when I try the mirc link, my cpu usage goes up and I loose focus on the window i have active just as if the prog is gonna open but it doesn't.
 
P

PC-Dude

Guest
#14
Originally posted by djwhite
Is it only mirc that doesn't work, can you get any other links to work (apart from run and sol)
Only the run and sol have worked so far and I have tried many different progs too.
 
P

PC-Dude

Guest
#16
Originally posted by djwhite
Can you get any 'Windows' programs to work eg. explorer, notepad, control panel?
Nope not yet , gonna try em when i get home from work today.
 
P

PC-Dude

Guest
#17
Ok I can get notepad to work however when i tried Explorer it wouldn't work. Only works on some progs....I don't know what to do now. Hey Madmatt if your around ...give me some tips ;)
 
P

PC-Dude

Guest
#18
Seems like any program that isn't in the windows dir won't run. I've tried 10 and still no go take the same settings and put notepad link in it and everything works.
 

madmatt

Bow Down to the King
Political User
#19
Leave me the following info and I will reply tomorrow when I wake up.

What OS?
What filesystem?
What drive are you running from?

Think that's all I need.
 
P

PC-Dude

Guest
#20
Originally posted by madmatt
Leave me the following info and I will reply tomorrow when I wake up.

What OS?
What filesystem?
What drive are you running from?

Think that's all I need.
Thanks Madmatt for your help :D

Windows XP SP1 Pro

Drive C - Windows ME
Drive D - Backup Drive (Fat32)
Drive E - Windows XP (NTFS)
Drive F - Applications etc (Fat32)


I can run pretty well any program that's in the windows dir, however as soon as i make a shortcut to a program outside the windows folder , they don't load. It's like something is stopping it from loading. My cpu usage will go up right after i click the link so I know something is working but the program doesn't load and the cpu usage goes back down after a few secs.

Hope this helps, and thanks once again
;)
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,962
Messages
673,247
Members
89,019
Latest member
fontjohnson