Hp dv9000z problem

Vanquished

Mr. Bananagrabber
Political Access
Joined
12 Jan 2006
Messages
4,869
Hey everyone,
I dropped my laptop from about six inches onto its back right corner and now the screen won't turn on. The blue lights turn on, the fan turns on and I believe the hdd turns on. but the screen stays dark, I have already taken the screen off and checked to see if the cables to the back of the screen are fastened (They are), and I'm wondering what else could be the problem. I'm trying to find the schematics to check if the video cable is plugged into the videocard on the motherboard. other than that. Any suggestions? Does anybody happen to know where I can find those schematics to access the video card? The screen does still work I guess, when I plugged in the inverter it lit up white for a second then nothing, so im assuming that its disconnected at the video card. Also the quickplay buttons will start the computer, so its definitely a display issue.

Thanks,
Jack

Its an hp pavilion dv9000z laptop.
 

Vanquished

Mr. Bananagrabber
Political Access
Joined
12 Jan 2006
Messages
4,869
Hey everyone,
I dropped my laptop from about six inches onto its back right corner and now the screen won't turn on. The blue lights turn on, the fan turns on and I believe the hdd turns on. but the screen stays dark, I have already taken the screen off and checked to see if the cables to the back of the screen are fastened (They are), and I'm wondering what else could be the problem. I'm trying to find the schematics to check if the video cable is plugged into the videocard on the motherboard. other than that. Any suggestions? Does anybody happen to know where I can find those schematics to access the video card? The screen does still work I guess, when I plugged in the inverter it lit up white for a second then nothing, so im assuming that its disconnected at the video card. Also the quickplay buttons will start the computer, so its definitely a display issue.

Thanks,
Jack

Its an hp pavilion dv9000z laptop.
Got it fixed by the way, just had to disassemble it, secure the lose cable and then reset the ram.

All good, thanks.
 

Members online

No members online now.

Latest profile posts

hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.
Terrahertz wrote on Electronic Punk's profile.
Yo fellas!
Electronic Punk wrote on Sazar's profile.
Where are you buddy?
Perris Calderon wrote on Electronic Punk's profile.
Hey EP! All good with me, applying for Microsoft MVP right now, should have done this a while ago.

Notifications don't work, I only found your response by coming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier!

Forum statistics

Threads
61,999
Messages
673,424
Members
5,592
Latest member
Rhilani