• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

How to remove "local disk" in win 7 explorer

hansrijf

sh! it stinks
#1
[SOLVED] How to remove "local disk" in win 7 explorer

Hello again,

a couple of days ago I attached two portable disks to my laptop. In windows explorer they showed up as disk L: and U:.

Now I cannot remove these references to these disks, so even though the disks are no longer attached to my laptop they still show up in explorer. I tried to find something in the register editor but I did not find anything related to L: or U:.

How can I remove these disks in explorer?

Thanks!

In the attachment: lokale schijf = local disk
 

Attachments

Last edited:

Johnny

.. Commodore ..
Political User
#4
Did you try to reboot your pc? Also, check bios and make sure they aren't still listed there.
 

American Zombie

Administrator
Staff member
Political User
#6
They may be one of the ??volumes further up the list.

Right click on the entries and select Modify binary data

See if the drive name is there in the data.

You can also just delete all the entries as Windows will re-create all devices still connected when you reboot.
 

hansrijf

sh! it stinks
#7
They may be one of the ??volumes further up the list.

Right click on the entries and select Modify binary data

See if the drive name is there in the data.

You can also just delete all the entries as Windows will re-create all devices still connected when you reboot.
I already looked in the entries but did not find the drivernames there. Will try to delete the entries, see what will happen...

Update: deleted the entries, rebooted, the disks are still there....
 

American Zombie

Administrator
Staff member
Political User
#8
Might be ghosted devices that are hidden.

Open an command prompt and type the following then push enter:

set devmgr_show_nonpresent_devices=1

Now type the following and press enter:

devmgmt.msc

When device manager opens go to the top and select View > show hidden devices

Now look in Disk drives and perhaps USB in device manager for your rogue entries.
 

hansrijf

sh! it stinks
#9
Might be ghosted devices that are hidden.

Open an command prompt and type the following then push enter:

set devmgr_show_nonpresent_devices=1

Now type the following and press enter:

devmgmt.msc

When device manager opens go to the top and select View > show hidden devices

Now look in Disk drives and perhaps USB in device manager for your rogue entries.
Good tip, hadn't thought of this yet. But .. did it like you said, removed all the items in devicemanager that might point to the two local disks, rebooted ... they are still there....:devious:
 

hansrijf

sh! it stinks
#12
I would attach them again and then do [Safely remove hardware option] if you haven't tried that.
Tried this, thing is these disk are ext3 formatted to use with Linksys NSLU2. To see these disks in Win7 I had to install a driver. When I reinstalled this driver yesterday I could not assign the driveletters L and U because they are already in use...
 

Terrahertz

Extinction Agenda
Political User
#14
Tried this, thing is these disk are ext3 formatted to use with Linksys NSLU2. To see these disks in Win7 I had to install a driver. When I reinstalled this driver yesterday I could not assign the driveletters L and U because they are already in use...
Hmm could they have been setup to reconnect at logon? I'm just throwing something out there until we can figure it out. Right click my computer and select disconnect network drives. If you haven't done this see if that's the problem.
 

hansrijf

sh! it stinks
#15
Hmm could they have been setup to reconnect at logon? I'm just throwing something out there until we can figure it out. Right click my computer and select disconnect network drives. If you haven't done this see if that's the problem.
Tried this too, the disks are no network drives... they are listed as "other" in explorer (my computer)
 

Attachments

American Zombie

Administrator
Staff member
Political User
#18
Re-attach the drives then open a command prompt and type diskpart

Wait until you get to the diskpart prompt then type list volume

If the drives or drive letters are listed then type select volume followed by the letter you want to select select volume L

Once selected type remove letter=L

Do the same for the other drive letter you want to remove.
 

hansrijf

sh! it stinks
#19
Re-attach the drives then open a command prompt and type diskpart

Wait until you get to the diskpart prompt then type list volume

If the drives or drive letters are listed then type select volume followed by the letter you want to select select volume L

Once selected type remove letter=L

Do the same for the other drive letter you want to remove.
Thanks for your suggestion. I reconnected the drives, loaded a command prompt, types diskpart and then list volumes .... see attachment for the result....
 

Attachments

American Zombie

Administrator
Staff member
Political User
#20
See if those drives are listed in system protection and if protection is turned on for them and/or if they say missing.

If protection is on and/or they are missing turn protection off for the drives and they should then disappear.

Another idea is if they are listed in the bcd file somehow.

Open a command prompt and type:

bcdedit /enum all

Copy/paste the result
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,014
Latest member
sanoravies