• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Halo refresh rate problem

#1
I got the game this morning, installed it, it gave me a direct 3D error. I downloaded latest Dets it started ok. I ran reforce to get around the 60 mgz refresh problem in XP and it then gave me the same error. Is there a way around this like in BF 1942. I am in work now I will have another go tonight. :mad:
 
#2
the only way i have found to keep Halo running in WinXP is to right click on the shortcut and in the compatibility mode tab set it to Win98 compatibility mode. the only downside to this is that in multiplayer you are not able to read any chatting.
 
V

Vorpal

Guest
#3
Originally posted by Dogfighter
I got the game this morning, installed it, it gave me a direct 3D error. I downloaded latest Dets it started ok. I ran reforce to get around the 60 mgz refresh problem in XP and it then gave me the same error. Is there a way around this like in BF 1942. I am in work now I will have another go tonight. :mad:
If ReForce does not work, you can also try RefreshLock which is more up to date and has more options:

http://www.pagehosting.co.uk/rl

Also be sure you have SP1 installed.
 
#4
I don’t think it is a ReForce Problem, I will try resetting my refresh rate to 60 mgz, and start the game, in the graphic menu I saw a refresh rate setting which was defaulted to 60 mgz , I will set that to 75 mgz and then run ReForce again @ 75 mgz and see if the game will start then.
 

Krux

Nissan Powered
#5
Halo isn't frefresh rate locked at 60hz. and Ive never understood this 60hz thing ive never had that problem.... is it and Nvidia thing or what?
 
Z

Zomaar

Guest
#6
Originally posted by Yharn
the only way i have found to keep Halo running in WinXP is to right click on the shortcut and in the compatibility mode tab set it to Win98 compatibility mode. the only downside to this is that in multiplayer you are not able to read any chatting.
try this right click on the shortcut and ad after halo.exe

-vidmode 1024,768,100

this is ofcource for resolution 1024/768
after exe must be a space
this worked for me
 

Doom

OSNN Senior Addict
#7
Originally posted by Zomaar
try this right click on the shortcut and ad after halo.exe

-vidmode 1024,768,100

this is ofcource for resolution 1024/768
after exe must be a space
this worked for me
You've totaly lost me there. What do you mean?
 
Z

Zomaar

Guest
#8
i mean, if you have the prob. the game is giving an error on d3d
you can fix the prob.
by rightclick at the shortcut then press properties ->shortcut and paste the text in target-->> -vidmode 1024,768,100
like this -> H:\Games\Halo\halo.exe -vidmode 1024,768,100 <-this is only a example

hope this will clear up :)
 
#10
pretty dumb to have to do that right outta the box i mean we pay good money and then have to figure how to run the **** because it won't run right.
 

Doom

OSNN Senior Addict
#11
I'm still a little lost with this. When I do it to the shortcut for it on my desktop I get a box coming up telling me that the target is not valid.
 
Z

Zomaar

Guest
#12
make a shortcut from the exe where the game is installed on your desktop
then go to the shortcut on your desktop and right click
then go to properties
then you see "target" in here you see the link were the prog is starting (your dir. where it is installed)
it is something like this "H:\Games\Halo\halo.exe"
then go to the end after halo.exe
there must be 1 space and then put this after it -vidmode 1024,768,100
it is going to look like this"H:\Games\Halo\halo.exe -vidmode 1024,768,100"
hope it will work now
we keep on trying

:)
 

Terrahertz

Extinction Agenda
Political User
#14
Originally posted by Krux
Halo isn't frefresh rate locked at 60hz. and Ive never understood this 60hz thing ive never had that problem.... is it and Nvidia thing or what?
Yup its a Nvidia thing. we all have to do a refresh rate fix
 
#15
I think everyone agrees that this issue needed to be addressed a little better before they released the pc version...Oh well..

I have a fairly high-end system and out of the box halo played like crap for me. My brother-in-law has a mid-range system with a cheaper nvidia card and it played like a dream for him...go figure..
ANYWAYS, here is what worked for my system..hopefully it will save you some time..give it a try.

My system:
WinXP Pro
Lots of Harddrives
Nvidia GF4 4400 (latest drivers from Nvidia)
Asus A7N8X-Deluxe (+ latest n-force drivers)
Onboard sound
blah, blah, blah...

Bottom line is to add some qualifiers to your shortcut (as zomar suggested)
..besides the refresh fix listed above it helps if you specify the pixelshaders that you want the game to use. I found for my nvidia card PS1.4 work the best (I have included a listing of all the options at the end of the post)

I have EVERYTHING set to HIGH, and I am using sound Hardware acceleration (YES)...BUT TURN OFF EAX.

I run at 1024x768 and I am specifying a Refresh rate of 85. (my monitor's actual refresh rate is set much higher)

in game set the FRAMERATE= VSYNC

Once again all ingame settings are set to either YES or HIGH except for EAX which is OFF. (Antialiasing is turned off in the Nvidia control panel, but the "controlled by application" works also)



To get this to work on my machine add the following to the last part of the shortcut (as outlined above):

-vidmode 1024,768,85 -use14

So that your shortcut will be:


"H:\Games\Halo\halo.exe" -vidmode 1024,768,85 -use14

(your drive/folders may be different)
if you want to try the PixelShaders 1.1 then simply change to -use11.

Hope this helps some of you out with this very frustrating problem.

Here is a list of the Commands you can append:

To add the command line:

"C:\Program Files\Microsoft Games\Halo\halo.exe" -vidmode 1024,768,85 -use14

Other commands you can tack on (straight from the Readme.rtf)

-nosound
Disables all sound.

-novideo
Disables video playback.

-nojoystick
Disables joystick/gamepads.

-nogamma
Disables adjustment of gamma.

-useff
Forces the game to run as a fixed function card.

-use11
Forces the game to run as a shader 1.1 card.

-use20
Forces the game to run as a shader 2.0 card.

-safemode
Disables as much as possible from the game.

-window
Runs the game in a window.

-width640
Forces the game to run at 640x480.

-vidmode w,h,r
Forces the game to run at width, height, refresh rate.

-adapter x
Forces the game to run fullscreen on a multimon adaptor.

-port x
Server port address used when hosting games.

-cport x
Client port address used when joining games.

-ip x.x.x.x
Server IP address used when you have multiple IP addresses.

-screenshot
Enables the "Print Screen" key to generate screenshots

-timedemo
Runs four movies and writes out timedemo.txt.

-console
Enables the debugging console.
 
B

blackspawn

Guest
#19
Well it seems that using LPDad's "-vidmode 1024,768,85 -use14" fixed whatever problems were occurring (was getting a BSOD everytime I tried to change refresh rate or screen resolution)

Thanks a bunch!! :D
 
#20
Yup its a Nvidia thing. we all have to do a refresh rate fix
NO it's an XP thing that's been corrected with SP1 (except for OpenGL). You don't need any apps to override the default 60 in D3D. Just go into 'More help' in dxdiag and set the override to whatever you prefer.
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,014
Latest member
sanoravies