get rid of "open with notepad"

fantasi

My Yngy is My HoneY!
#1
hi guys, just formatted my pc... again :/ and thought i would use the autopatcher, well anyways in one of the tweaks it has "open with notepad on unknown extension" i think it was called. well i had a similar tweak taht would allow a right click open with notepad already and i thought this was the same. But what that tweak does is, any file that is unknown is opend with notepad. so a dat or .bc! or any file extension is opend with notepad which is kinda annoying. Is there a registry tweak to undo this?
 

madmatt

Bow Down to the King
Political User
#2
Code:
HKEY_CLASSES_ROOT\Unknown\shell
    (Default)   REG_SZ  openas
Code:
HKEY_CLASSES_ROOT\Unknown\shell\openas\command
    (Default)   REG_EXPAND_SZ   %SystemRoot%\system32\rundll32.exe %SystemRoot%\system32\shell32.dll,OpenAs_RunDLL %1
Delete both and you should be fixed.
 

Hipster Doofus

Good grief Charlie Brown
#4
Backup your registry first. I have not tried these.

Check your settings here:

1/ HKEY_CLASSES_ROOT\Applications. Select the associated sub-key, if 'NoOpenWith' is listed, delete it.

This setting allows you to control whether the checkbox to save the "Open With" program is available when an unknown file type is opened.

HKEY_CLASSES_ROOT\Unknown\shell\openas\command

To enable the checkbox set the (Default) value to "rundll32.exe shell32.dll,OpenAs_RunDLL %1".
Return to the desktop and press F5 for the change to take effect.

2/ Get rid of "Open With" Items in Right-Click

When right clicking any file you're likely to see an option called "open with", which lists any available program on you computer to open the file with. To simply clear up this list of unwanted items, or to remove useless associations, like opening an mp3 file with a paint program, follow these steps:

- Start Regedit
- Navigate to
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts

Find the extension you wish to edit and click on the "+"-sign to locate the key that says "OpenWithList"

In the right pane of the registry editor you'll see a list with the programs in the list, like "paint.exe" or "notepad.exe"
Simply click on the one you wish to delete and press the delete button on your keyboard

Don't worry if you've removed an entry you rather hadn't removed. When right clicking a file there will be another option in the "open with" extension where you can choose any program on your computer. Once used, it will reappear in the list of associated programs.
 

fantasi

My Yngy is My HoneY!
#5
i tried them all dufus but it didnt work :(. so i went to run autopatcher again and i saw this when i right click that particular tweak

HKLM\Software\AutoPatcher\Tweaks\Functionality\openwithnotepadnoextension=20041229

can i delete that? or is there a default that i can edit?
 

Hipster Doofus

Good grief Charlie Brown
#6
Back up the registry, delete it, reboot, see if that has got it. If not reinstall the registry. Or simply rename the the above....after noting the name now, reboot, see what gives. If it has done the trick then delete it.
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,971
Messages
673,299
Members
89,016
Latest member
Poseeut