• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

FTP Server and Linksys BEFSR41 Router

S

Spyder1125

Guest
#1
Trying to get my ftp server up and running for quite some time. It sometimes works for me when I type in the IP address, but when I ask other people to try it, they say it doesn't work. I've tried running it through SERV-U and BPFTP and neither work. I would like to know what settings I need to make on my router settings, and which IP address to use, and how to obtain that IP address. Also what settings to use on SERV-U FTP. Any help is appreciated, thanks.
 

JJB6486

Retired Mod
Political User
#2
Read the FTP software's manual and figure out how to set a custom passive port range.

Then read the router's manual and forward port 21 and whatever the range you set for passive was.

JJB6486
 
S

Spyder1125

Guest
#3
i set the passive port range numbers to be 23580-23590. i dont know what to do now...i'm looking at my router settings and i'm in the "forwarding" tab what should i do next, forward the passive port range numbers to my local computer ip, which would be 192.168.1.100? Also, i see there's an option in SERV-U ftp that has an option that says "Allow passive mode data transfers, use IP _________" Should I have this option checked off, and which IP address would I use, and how would I find it?
 

JJB6486

Retired Mod
Political User
#4
The IP for passive is your EXTERNAL IP (the public internet one).

Enable passive transfers, and set up two forwards. One with the range of 23580-23590 and the other 21-21, both going to 192.168.1.100

JJB6486
 
L

Lytener

Guest
#6
Software based

It might be software based.

Microsoft services are mostly background apps. One is called ICF, Internet Connection Firewall. Most likely it was enabled during the setup of your network if you've set it up so that one computer is acting as a router/NAT. I agree that everyone should use a firewall; just not Microsoft's.

To check if its enabled or not:
1. Go to Settings > Network Connections
2. Right-click on your Internet connection and select Properties
3. Go to the Advanced Tab

The settings for ICS and ICF should be right in front of you. If it's enabled, just disable ICF. Or if insist on using Microsoft's firewall, click on Settings and continue to read:

4. Here you will see which services you can enable. You have your basic services such running a FTP server, POP/SMTP server, Telnet Server, Web server, whatever server. If you want to add a different kind of service click add.

In your case you will want to check FTP server. Hit 'OK'. Hit 'OK' in the Properties dialog and you are all done.

I hope that worked for you. This article also applies to anything such as 425 connections or basically anything if you have a firewall already installed and you are wondering what the heck is going on after you've permitted the specific events.

Cheers,

Lytener
 
C

Cigar

Guest
#7
i read on the net that ppl who are behind a router and connect to an ftp server wich is also behind a router can't connect to a different port than 21 .

i can't tell if someone has fix this problem, but if it could help someone i'm also running a linksys router and the only other ppl (behind a router) can connect to my server is thru port 21 .

here's a simple table of what i experienced

on port 21
----------------
router to router = ok
w/o router to router = ok
w/o router to w/o router = ok

on a different port than 21
-----------------------------------
router to router = failed
w/o router to router = ok
w/o router to w/o router = ok


if someone now how to avoide this plz feel free to mail me

keep in mind that i got the lastest firmware on :)

switch180qc@hotmail.com
 
N

neoterixx

Guest
#8
I to have your router and using server-u ftp server. Here is what you need to do

simply inside of the SETUP>FTP SERVER>IP HOMES =

Home IP should be whatever your ip is (ipconfig /all in the RUN>CMD will tell you this) Put in the IP for passive mode your actual OUTSIDE ip, do a whois in www.dslreports.com >DSLR TOOLS> WHOIS to find this out or just check your router DHCP tables. It should work fine from here, and if your FWRDING ips make sure your FWDING to the right ip. :D
 
#9
Spyder1125,

i struggled with this problem for a couple of weeks. with the help of people in the xp-erience.org forums and this link, i was able to get my ftp running in minutes.

i have the same set-up....winxp pro, linksys befsr41 router, cable connection with road runner.

you'll have to sign up with tzo.com or another dns service. they keep track of your wan ip so users can connect to a domain like, Spyder1125.myftpserver.com.

just follow the instructions in the link i gave above and you'll have your ftp online in 5 minutes! i promise!

if you have any problems, please feel free to email me here.

hope this helps... :)
 

Members online

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,962
Messages
673,247
Members
89,020
Latest member
saryrehgy