Folders are set to read only

Discussion in 'Windows Desktop Systems' started by Awwjwah, Nov 21, 2002.

  1. Awwjwah

    Awwjwah Guest

    I am going to post this here and in another thread because I don't know where to begin. I just recently noticed that all the folders on my XP machine are set to read only access. I don't know how, why or when this happened but i just noticed it last night. I tried to change it but cannot figure it out. Can anyone help or have an idea as to what to do?

    The most recent problem I had was a system hang up on me while installing Unreal Tourny 2K3. The disc hung on a bad/corrupted file. Before that I havn't had a problem. I don't know where to begin or what to look for.
  2. Streaatz

    Streaatz Guest

    Sorry, can't help ya. :)
  3. Kevin Ar18

    Kevin Ar18 OSNN Senior Addict

    I would think this could be done by changing the security settings for the files on your computer. It would require a person to log into an Administrator level account.

    Some questions:
    Do you have XP Home or Pro?
    Does anyone at your house have an Administrator level account and could they have messed with your computer?
    Are you on an Administrator level account, a limited account, or a custom account?
  4. Awwjwah

    Awwjwah Guest

    It's my home pc and I am the single user on it. It is XP pro and mMy account is set to admin level.
  5. Kevin Ar18

    Kevin Ar18 OSNN Senior Addict

    Can you log into the "Administrator" account? There might also be an "Owner" account, but I'm not sure. In XP Home you have to boot into safe moded in order to access the Administrator account.

    If you can, go into that account and check what settings are setup for your account that you normally use. You might also want to add a password to this hidden "Administrator" and/or "Owner" account (if XP Pro doesn't have one) so people can't log onto your machine from the net.
  6. Awwjwah

    Awwjwah Guest

    Well I went into safe mode and the folders are read only there as well. A friend who has been helping recommended a rebuild since even at that level under adin it is messed up. Any other suggestions?
  7. Kevin Ar18

    Kevin Ar18 OSNN Senior Addict

    1 Open up Windows Explorer or My Computer
    2 Right click on the C: Drive and select Properties
    3 Goto the Security tab
    4 In the "Group or user names:" pane click on each one listed and look at the settings for them in the bottom pane entitled "Permissions for Administrators"
    5 Take note of the one entitled "Administrators (NAMEOFCOMPUTER\Administrators)"
    6 For Administrators, in the bottom pane, all things should be checked to allow. If not then, there is of course a problem, and it needs fixing.

    1. While you have Administrators selected, click on the "Advanced" button.
    2. You should be in the "Permissions" tab now.
    3. Select the Administrators group.
    4. Click Edit...
    5. Check Allow for everything.
    6. Hit OK
    7. Hit Ok
    8. Hit Apply

    That should give you access back again, however, it may be that your "Administrators" group settings have been messed up.

    However, since I only have XP Home I can't tell you how to do it, but I think you can use the group policy editor to change things:;en-us;Q307882&sd=tech#2
    Basically you will need to find your Administrators group (wherever it is at in that program) and make sure it's settings are set to allow everything.

    P.S. You might also want to put a password on your Administrator account to be on the safe side.
  8. Kevin Ar18

    Kevin Ar18 OSNN Senior Addict

    BTW, the above is for when you are logged into the Administrator account.
  9. Khayman

    Khayman I'm sorry Hal... Political User Folding Team

    Mine is also set to read only, always has been (i know other who have as well). So far its made absolutely no difference.
    So unless your having a problem because of it, i wouldn't worry
  10. Awwjwah

    Awwjwah Guest

    hey kevin. Ok I checked that and the pane had everything checked. I went through unchecked and rechecked everything just to be sure but still no change. I notice this problem only with certain directories and it is really confusing teh heck outta me. I have a feeling I'm gonna end up wiping this system clean and re-installing. No biggie really excet for the wasted time of a reload.
  11. Fu Xuen

    Fu Xuen Guest

    I think this option isn't actually checked but grey tinted : it means some files within the current folder are set to read only, but not the whole content.
  12. Shamus MacNoob

    Shamus MacNoob Moderator Political User

    L'Ile Perrot Quebec
    Mine also

    And mine also is this way .. as far as I know its normal and I dont see why your busting your brain over it....... mine has always been this way I have been using XP in one form or another for well over a year and it runs fine with the so called read only folders? Only time a read only file is a problem is sometimes after backing up something to a cdrom.. and copy/pasting it back it sometimes makes the file a read only this is no good in certain things ie a game save file ... so then its just a question of highlighting the file/files and right click go to properties and changeing the read only option ...... other than that relax and stop busting your head over it ...;)
  13. Kevin Ar18

    Kevin Ar18 OSNN Senior Addict

    After reading these other posts, I finally realized what you are talking about. Sorry about the mistake.

    You are referring to the read only attribute on the files/folders correct?

    To change is simply highlight all the files and folders you want to change and right click and select properties. Then uncheck the read only attribute.

    When you say all of your files are read only? Do you literally mean all of them?