• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Few questions

#1
Ok, I've got a few questions! I'm going to switch my home pc to Ubuntu, but I have a drive that has all my music on it (seperate drive) that is formatted in ntfs. Question is how can I read the drive? Also what is a good media player? I'm using the built in one which is ok, but it doesn't give me the name of the cd or song titles. Plus i'm sure i'll have more questions soon (n00b here)!
 
#3
hmmm...i'm not able to mount it! I did exactly what it said to do and then some!
Here is what I show when I do sudo fdisk -l
/dev/hdb1 * 1 12703 6002136 83 Linux
/dev/hdb2 12704 13328 295312+ f W95 Ext'd (LBA)
/dev/hdb5 12704 13328 295281 82 Linux swap

here is my fstab
/dev/hdb2 /mnt/winxp ntfs ro,auto,uid=1000,gid=1000 0 0

now i have tried it both with mkdir w95 and mkdir winxp. What am I doing wrong?
 
#6
Ah, I think I see the problem. It's looking at the wrong physical disk. Try both of these commands, and copy/paste the output that you get here.
Code:
fdisk -l /dev/hda
fdisk -l /dev/hdc
 
#8
Here is what I get when I try to mount it
mount: wrong fs type, bad option, bad superblock on /dev/hdb2,
or too many mounted file systems
(aren't you trying to mount an extended partition,
instead of some logical partition inside?)

what is interesting is the line from fdisk -l
/dev/hdb2 12704 13328 295312+ f W95 Ext'd (LBA) <---extended

should I be doing something different?
 

j79zlr

Glaanies script monkey
Political User
#9
hmm, couple things here, what if any error messages are in dmesg concerning your fstab?

Does the mount point exist?

your fdisk -l is showing it formatted as fat32 aka vfat, if it were NTFS, it would show up as HPFS/NTFS


I would first just try mounting it, and getting that to work, then edit fstab to have it done at boot automatically. Since it appears to be vfat, just run

mount -t vfat /dev/hdb2 /mnt/winxp

After you edit fstab, you do not need to reboot to test your fstab entries, just run

mount /dev/hdb2

It will read the options from fstab.
 

j79zlr

Glaanies script monkey
Political User
#10
If you want some examples, take a look at my fdisk -l, and /etc/fstab:

Code:
wrkstn3 ~ # fdisk -l

Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        2611    20972826    7  HPFS/NTFS
/dev/hda2            2612        5222    20972857+  83  Linux
/dev/hda3            5223        7833    20972857+  a5  FreeBSD
/dev/hda4            7834        9729    15229620    c  W95 FAT32 (LBA)

Disk /dev/hde: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hde1               1        9207    73955196    7  HPFS/NTFS
/dev/hde2            9208        9468     2096482+   c  W95 FAT32 (LBA)
/dev/hde3            9469        9599     1052257+  82  Linux swap / Solaris
/dev/hde4   *        9600        9729     1044225   a5  FreeBSD
wrkstn3 ~ #
Code:
wrkstn3 ~ # more /etc/fstab
# <fs>                  <mountpoint>    <type>          <opts>                  <dump/pass>

# Root and swap file systems
/dev/hda2               /               reiserfs        noatime                 0 0
/dev/hde3               none            swap            sw                      0 0

# NOTE: The next line is critical for boot!
none                    /proc           proc            defaults                0 0

# glibc 2.2 tmpfs mount
none                    /dev/shm        tmpfs           defaults                0 0

# Removable media
/dev/hdc                /mnt/cdrom      iso9660         noauto,ro,users         0 0
/dev/hdd                /mnt/cdrw       iso9660         noauto,rw,users         0 0
/dev/fd0                /mnt/floppy     vfat            noauto,users            0 0
/dev/hdb4               /mnt/zip        vfat            noauto,users            0 0
/dev/sda1               /mnt/usbstick   vfat            noauto,users            0 0

# Windows mounts
/dev/hda1               /winxp          ntfs            defaults,umask=0222     0 0
/dev/hda4               /winshare       vfat            defaults,umask=0        0 0
/dev/hde1               /winro          ntfs            defaults,umask=0222     0 0

# FreeBSD mounts
/dev/hda5               /freebsd        ufs             ufstype=ufs2,ro         0 0
/dev/hda6               /freebsd/tmp    ufs             ufstype=ufs2,ro         0 0
/dev/hda7               /freebsd/var    ufs             ufstype=ufs2,ro         0 0
/dev/hda8               /freebsd/usr    ufs             ufstype=ufs2,ro         0 0



wrkstn3 ~ #
http://www.j79zlr.com/howto.php?id=20
 
#11
The thing is, I don't think any of the partitions listed are the one you want. In your first post, you mentioned that the NTFS partition is on a separate physical disk. /dev/hdb is the disk that you've installed Ubuntu on (as you can see from the 'fdisk -l' output).

It doesn't seem to be detecting the other physical disk that contains the NTFS partition.
 
#12
j79zlr said:
hmm, couple things here, what if any error messages are in dmesg concerning your fstab?

Does the mount point exist?

your fdisk -l is showing it formatted as fat32 aka vfat, if it were NTFS, it would show up as HPFS/NTFS


I would first just try mounting it, and getting that to work, then edit fstab to have it done at boot automatically. Since it appears to be vfat, just run

mount -t vfat /dev/hdb2 /mnt/winxp

After you edit fstab, you do not need to reboot to test your fstab entries, just run

mount /dev/hdb2

It will read the options from fstab.
It ran it but it tells me the same thing.

jon@Easyrider:~ $ sudo mount -t vfat /dev/hdb2 /mnt/winxp
mount: wrong fs type, bad option, bad superblock on /dev/hdb2,
or too many mounted file systems
(aren't you trying to mount an extended partition,
instead of some logical partition inside?)
 
#13
The way I'm seeing it:

/dev/hdb: Physical disk containing the Linux partition
- /dev/hdb1: (Primary) Linux partition (ext3?)
- /dev/hdb2: (Extended)
- - /dev/hdb5: (Logical) Linux swap partition

That's the reason you can't mount /dev/hdb2; it's not a mountable partition. The second physical disk (which should have been /dev/hda, /dev/hdc or /dev/hdd) containing the NTFS partition is not being detected at all.
 
#15
NetRyder said:
The way I'm seeing it:

/dev/hdb: Physical disk containing the Linux partition
- /dev/hdb1: (Primary) Linux partition (ext3?)
- /dev/hdb2: (Extended)
- - /dev/hdb5: (Logical) Linux swap partition

That's the reason you can't mount /dev/hdb2; it's not a mountable partition. The second physical disk (which should have been /dev/hda, /dev/hdc or /dev/hdd) containing the NTFS partition is not being detected at all.
that sounds logical...so then how do I get it detected?
LordOfLA when I run that I get
mount: special device 5130a does not exist
jon@Easyrider:~ $ mount
/dev/hdb1 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
 

j79zlr

Glaanies script monkey
Political User
#17
Could you run:

dmesg | grep hda

and post the output.

Actually, could you also post your configuration, IDE channels and partitions.

e.g. primary and/or secondary IDE channel, master, slave, and the partitions.
 
#18
It sees it in Device manager (see picture).
dmesg
jon@Easyrider:~ $ dmesg | grep hda
ide0: BM-DMA at 0xd800-0xd807, BIOS settings: hda : DMA, hdb : DMA
hda: IRQ probe failed (0xfffffdf8)
hda: ATAPI 48X CDROM, ATAPI CD/DVD-ROM drive
hda: ATAPI 48X CD-ROM drive, 128kB Cache, UDMA(33)

As far as configuration
IDE1 = Cd drive (master)
Western digital (slave) 6-gig
IDE2 = Maxtor (slave) 20 gig <--maybe it being a slave is the issue?
 

Attachments

#20
what if I run "dmesg | grep hda" but instead of hda use hdb, what will that do? I also change the second disk to a master. Should I maybe have both disks on the same IDE?
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,012
Latest member
Sierge