• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fasttrak 66 IDE Raid + WinXP Woes

Z

zhardoum

Guest
#1
Hello all, I am desperately doing battle with installing Windows XP and I seem to be losing badly.

I have a Fasttrack 66 IDE Raid card with 2 IBM 35 GB Deskstars in stripe 0 array.

That sits on an Asus K7m Mainboard, Athalon K7 800 keeping it warm, 256MB of ram to play with, Canon Scsi Scanner card (which is an adaptec AIC 7850) and another Adaptec 2940OU card next to that which talks to my Plextor 12speed SCSI CDRW

My 3d Prophett DDR DVI card (MK1) serves to trap your finger when you try to get near the creative labs live card which is buried right underneath the 3com 3c905 TX network card.

Other than that, a trusty dvdrom drive is hooked up as seconday slave onto the mainboard ide slot2.

I am trying to put XP pro on top of windows ME.

However, I get the famous blue screen of death with the stop message 0x0000007f (inaccessible boot device).

That message appears when I am trying to run the XP installer..after its done the diag bit in ME and reboots

Ok says me, I know, the XP boot thinks the raid is SCSI so I need to load the IDE Raid drivers for the raid card..

pressed F6, inserted floppy that came with the card when new (1.5 years ago) obviously there is no XP drivers on it, and XP said the the sys file on the A drive was corrupt so aborted...

Right says me, off to promise website for new drivers..

looked at FAQ's, looked at drivers, loaded it up, inserted disk, tried win 2000 driver for fasttrack TM card, it blue screened, same error.

tried Win 2000 for fasttrak 66 card, blue screened
tried Win 2000 for fasttrak 100 (helll i live in hope) bluescreened
tried Win 2000 for fasttrak tm 100 (again hopefull) bluescreened
Tried Nt for all listed.. bluescreened

Spent the next FIVE HOURS downloading every driver that even might stand a chance, everyone I tried blue screens same error message..

Promise website is more than useless, it says and i quote from memmory here "insert your promise familly raid driver disk that came with your product and after pressing F6 choose the Windows XP driver" !!!

Which is complete and utter tosh, not to mention the fact my driver disk is 1.5 years old. but nowhere on the Promise website does it mention any XP driver files, all it does mention however is "Windows XP may say the filter for the fasttrak card is incorrect, press enter and ignore it as windows XP works fine with this card without the filter so we havent released a driver!"

At this point I feel like paying them a visit with a tank!!

However, they are now shut till sometime mid january in the new year (or at least thats the telephone message)

so then, over to the good old helpfiles of microsofts technet, but of course, do a complete search for Fasttrak and not a mention, nor promise, eventually I found an obscure link to here..

But before I decided to write my woes down here, i dosconnected my DVD rom, who knows maybe its trying to load the boot sector onto it? anyway, still bluescreened.

removed Canon Scanner card - nope, still blue screened

removed plextor CD and Adaptec Scsi Card, nope, blue screened

Removed sound card, network card and everything else that comes off without going bang until I have mainboard, proc, ram, raid and 2 disks, floppy, and agp card

And it still blue screens

same error, 0x0000007f (inaccessible boot device).

Does anyone have a workaround for this, I want to install XP on the raid, I do not want to buy another IDE drive just so I can install XP.

I also have some 40GB's of work related stuff on the disks so a total wipe and clean install is also out (but thats not the problem anyway)

Anyone had this problem and managed to fix it without just putting in the driver disk, pressing F6, then S and it working perfectly, because mine isnt..

yes, I am desperate, yes its been a long day, yes I want to go and lie down, but before I do I want to install XP!!
 
S

Speed4Ever

Guest
#2
Is the controller on the XP HCL? If so, XP should already have the drivers for the controller.

Can you still get into ME?
 
Z

zhardoum

Guest
#3
fortunately the remove winxp installation option still works..

as to the drivers, the XP HCL site does not mention this card direct, but does mention its bigger brother the fastrack 100

when i tried the 100 drivers, it occasionaly said I was trying to use drivers older than the windows ones it had installed

didnt make any difference which way round i tried it, it blue screened all over the place..
 
Z

zhardoum

Guest
#4
I believe this is the card as listed with microsoft-

----------------------------------------------

Promise
Ultra 66

Device Notes:


--------------------------------------------------------------------------------
This Device meets the following logo-level classifications:

Windows 98: No Test Data
Windows Me: No Test Data
Windows NT4 x86: No Test Data
Windows 2000: No Test Data
Windows XP: Basic Compatibility Requirements
Windows XP 64-Bit: No Test Data

No additional notes are available at this time.

Drivers:


--------------------------------------------------------------------------------
No drivers or updates are available at this time.

Last Updated: Friday, December 28, 2001
© 2000 Microsoft Corporation. All rights reserved. Terms of Use



------------------------------------------


But, if it says no drivers are available, and promise has no drivers available, how the heck did they manage to test the dam thing..?
 
T

tOtEM

Guest
#5
THIS IS WHAT YOU MUST DO ...

At the start of the install of XP .. it will ask you to HIT F6 if you need to supply drivers for scsi .. WELL.. you do .. go to promise and grab the drivers for Win2k .. put them on a diskette .. when you hit f6 to provide drivers for RAID/SCSI card .. make sure the diskette with promise drivers are in .. select the Fasttrak 66 .. and away you go .. ..

Hope this helps ..
 
S

Speed4Ever

Guest
#6
Originally posted by tOtEM
THIS IS WHAT YOU MUST DO ...

At the start of the install of XP .. it will ask you to HIT F6 if you need to supply drivers for scsi .. WELL.. you do .. go to promise and grab the drivers for Win2k .. put them on a diskette .. when you hit f6 to provide drivers for RAID/SCSI card .. make sure the diskette with promise drivers are in .. select the Fasttrak 66 .. and away you go .. ..

Hope this helps ..
He already tried this...

looked at FAQ's, looked at drivers, loaded it up, inserted disk, tried win 2000 driver for fasttrack TM card, it blue screened, same error.
Dont worry, I'm kinda stumped also by this. If its on the HCL, it should work.

zhardoum, is this a PCI IDE controller, or built-in to the mainboard?

If its a PCI card, have you tried hooking the hard drive onto the primary IDE port?

Sorry if this sounds dense, I'm a bit under the weather today...
 
T

tOtEM

Guest
#7
OK .. I had a friend with the same type issue... BUT with a Abit board..

First, have you checked with Asus to see if theres an issue with RAID and there board ?

For ABIT there was, they posted a patch.. Didn't work anyways ..
SO we poped in a IDE drive and installed to his RAID set. Worked a hot dam. For what ever reason XP would not boot from the RAID set .. BUT did boot from the IDE and even though XP was installed on RAID set .. it worked. SO if you have a drive you can put on IDE channel, even a wee tiny drive. Only has to hold boot information, This DID work for above mentioned system

I have a Promise Fasttrack RAID setup. And didn't run into this issue

Quick question.. is your RAID card a hacked Ultra66 ?
 
Z

zhardoum

Guest
#8
Ok 2 things, firstly the raid card is a Fastrak Ultra 66 card, not hacked and its PCI not on board the Mainboard

Secondly, it is in a stripe..

So I cannot plug it onto the mainboard as it would destroy the data and the stripe, and I want to use XP on the Raid..


And yes, whoever said I tried it, i tried it, every driver for win2k and NT4 I could get my hands on, across all sorts of drivers from promise and even some home ones written by enthusiasts.

All had the same probelm, blue screen with the same message about boot sector..

Lastly, there is no mention on Asus about this board and the PCI card setup..
 
T

tOtEM

Guest
#9
OK .. I know your running RAID 0 ..

I know you can't take the stripe set and put it on the mainboard.. cause you don't have on board RAID ..

I said get a small drive .. get another drive ..
put it on IDE channel .. install XP onto your RAID setup .. the boot files will install onto the small IDE drive... and you now will beable to boot .. It's NOT a driver issue ...

Your not the first person to come up against this ..

solution .. must have a NON RAID boot drive..

Have no idea why .. since I have pretty much the same setup .. without an issue .. at all ..

A buddy of mine .. same issue as you .. We found a small drive .. put it in .. installed XP onto his RAID 0 .. boot files installed to the small IDE drive.. and it boot flawless ..
 
Z

zhardoum

Guest
#10
Ok, lets say I go with that.

What then with the applications and drive lettering

my current raid is as far as my pc is concerned 1 disk of 60+Gb..

obviously it is drive C:

So all the apps and so forth have their routes linking to c:\whateverfolder...

If I add an IDE drive, and windows XP installs the boot sector onto it, wont that be C: and my old Raid disk set now D:

In which case major headache time as far as the applications go..
 
T

tOtEM

Guest
#11
Well .. yes it does .. and thats not a good thang ..

I'm trying to replicait the error your getting and a test system.

see if I can come up with a solution... Just cause I can and don't mind ..
 
Z

zhardoum

Guest
#12
I don't know what to say.. thanks i suppose would be a good start..

however, please note it is the Fastrak ultra 66 Raid ide card, with 2 disks as one virtual disk

I have a snaeky suspicion the Ultra 100 card may work (judging by the numbers of drivers) but that the 66 card is as far as promise concerned obsolete so they can't be bothered writing a driver for it..
 
Z

zhardoum

Guest
#13
Well here I am , writing this using Windows XP at last.


But I cannot say I am that amused

after much investigation it turns out windows XP cannot handle IDE Raid boot devices, which meant I had to add an IDE Disk to allow it to load, which in the process completely, and I do mean completely, not even slightly, screwed up my raid array deleting everything..

including that 15GB of work I was desperate to keep.

some 7 hours later I am still just reinstalling office and other programs, god knows how long before its back as it was, and as for the data that must not be lost, about 4 years uninterrupted might do it..

Oh, and by the way, the first time windows XP loaded, it showed me the start bar options, found a printer.. and crashed

and I have upgraded the memmory to 756MB ram, just to play safe as well

oh boy I dont think I am going to like this one bit..

what I do like is the way they took the best bits out of NT4, WIN2k Pro and server, copied VNC, Copied Zone alarm and now pass it off as though Microsoft just invented it..

Of all Microsofts install's this must be by far and away the worst, since I have done something over 7,000 installs I know what I am talking about.

Oh, didnt I tell you, i asked the question above not because I am thick, but because the number rule of computing is, dont reinvent the wheel.

yours Sincerely

Zhardoum
MCSE
MCP *7
CNSE
CNE
and soon to be Unix certified

and believe me, installing Unix 7.11 on a multi array server farm was a damn sight easier that installing Xp @ home..

I live in fear..
 
Z

zhardoum

Guest
#14
And to make matters worse

it completely ignores my raid disk setup

no drivers work with it

it has now lost 65GB of nice raid storage.. give me 3 reasons why i shouldnt advise customers to stear clear of this product, apart from the fact microsoft in their wisdom no longer supply any other OS

I have won Microspfts Technet competitin 7 times out of 9, no they wont send me the the T shirt,m I dont live in the the US.

Maybe thats where I should have been paying attention, if you dont live in the US and therefore knock on the door, they dont give a damn!
 
Y

YooEntSinMeROYT

Guest
#15
I managed 2 get Win XP to recognise my RAID hard drive config that is setup through the Promise onboard controller on my Gigabyte Mobo.
Using XP drivers downloaded from Gigabyte's website & copying them onto a floppy.
So XP does recognise RAID devices, with the appropriate drivers
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,014
Latest member
sanoravies