• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

FastTrack TX 2000 Device Manager Question

Heeter

Overclocked Like A Mother
#1
Hi guys,

I jsut got a used Promise FastTrack TX2000 PCI RAID Card. Paid $20 bucks for it. I downloaded the drivers for it from PromiseTech site. I installed the drivers for it using the Device Manager. I also hooked up my 2 x 120GIG HD to it so I can MirrorRAID them. I rebooted machine once drivers were installed. I still cannot see the HD's in my Disk Manager, and when I open my Device Manager to see if it was installed, I have a second Promise item listed in the Device Manager with a question mark beside it. Here is a screenie of my Device Manager. Would someone be able to tell me what I need to do to get my RAID card working and my HD's showing up on my Disk Manager?

Thanks in advance,

Heeter
 

Attachments

Members online

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,962
Messages
673,240
Members
89,017
Latest member
loxioalix