• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

DVD Player Issues

SPeedY_B

I may actually be insane.
#1
Recently DVD player has been acting up, I've been trying to watch 24 seasons 1 and 2 and the image occasionally looks like so:


usually this only lasts for the 20th Century Fox intro, and then I'm able to see the DVD normally, however on the season 2 discs, it carries on until I'm actually in an episode (therefore I have to blind navigate the menus) on the most recent disc I'm trying it continues to display a garbled pic even into the episode. Had anyone else experienced problems like this?

OS X Version : 10.4.2
DVD Player Version : 4.6
Framework Version: 4.6.1
 

Xie

- geek -
#3
My guess would be some sort of copy protection crap interfering with normal functionality as normal. Have you tried checking it out with VLC or something?

Oh and one last thing .. not sure if it would help at all but did you grab 1.1 of the 2005-07 update?
 

SPeedY_B

I may actually be insane.
#4
Works fine in VLC.

Was talking to a friend about it and we came to the conclusion that it was the DVD decoder. As It only happens in DVD Player on the iBook (Software decoding... at a guess), and not the PowerMac (Hardware decoding).
 
#5
Looks like a Codec issue. I've seen radically different "quirks" as I mess with my installed codec packs. At one point I went back and took out all the extras (kazaa lite, matrovska, etc) because video playback was getting too quirky.

I also have one really freaky problem. Some of my computers will play AVI bigger than 700MB and some won't. This has to do with windows mismanagement of file sizes over 700MB. There is a fix for the 64 Bit Windows but not 32 BIT. I finally gave up on it and just use the machine where it works.
 

Xie

- geek -
#6
Interesting find SPeedY_B, glad you got it sorted, though not fixed. Perhaps you should file a bug report with Apple?
 
#7
I'll give it a shot on my iBook when I return from the dentist

returned from dentist, randomly selected Disc 3 from series 2 and it all worked fine.

DVD Player: 4.6 Framework: 4.6.1
OS X Version: 10.4.2 (with the latest 1.1 update thinger)
 
Last edited:

Xie

- geek -
#8
This is getting interesting as Geffy can't replicate this now. :p You both using same region DVD's? Perhaps it's a manufacturing issue that is random, and the iBook is less able to correct?
 

zeke_mo

(value not set)
Staff member
Political User
#10
Im not sure on how macs work, but try changing it from hardware decoding to software, or the other way :p I used to have a problem like that using the nvidia dvd player with an ATi card. I just changed it to software and it worked fine after that
 
Last edited:

SPeedY_B

I may actually be insane.
#11
Geffy said:
mmm
my dvds are all UK Region 2 from either Play or Amazon
iBook G4
1.2GHz
1.256GB RAM
9200 gfx card
These are from Play to my knowledge.

As you know, my iBook's the slightly older model: 1GHz G4, 768Mb, 9200 32mb.
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,015
Latest member
sanoravies