• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Disk in CD unrecognised - WINXP Pro

F

Flash

Guest
#1
Hello, perhaps someone could help with this problem. I have put up with it for quite a while and perhaps there is a resolution by now. Any assistance is appreciated.

When I have just booted and I place a data CD in my CD-RW (Aopen 40X) XP reports that there is NO disk in the unit, OR it will open with explorer yet there are no files shown.

To fix the issue I have to reboot with a data disk in the drive, once that is done everything is fine. I can see the files.

I have checked the Microsoft K base and I cannot find a definitive fix, other than a note in one article "you may have to modify the Windows Registry if you have more than 2 IDE devices". I have 2 Hard drives, 1 CR-R/RW and 1 CD/DVD.

Unfortunately I cannot find an article on how to and where in the Registry to increase (or verify) the number of IDE devices that are defined. However this may not be the problem at all.

Funny though, XP seems to know that it is a CD-RW drive.

I have a PIII 800Mhz EB, Asus MB (about 1 year old), 512MB SDRAM.

Thks & Regards,
Jim
 
B

Blue

Guest
#2
I've seen XP do that from time to time, but never consistently, as you describe .... Are you using a cdrw disk to write files to using a packet writer like DirectCD or InCD? Or are you trying to read data that has been previously burned to a cd? .... and of ocurse ... do you have the most recent updates for your packet software etc ... and any firmware updates to your cdrw? Also make sure your cd rom and cdrw are set up master or slave as per manufacturers specs ... they can be finicky there.


Having said all that ... in my experience WinXP can be pretty fickle when it comes to reading/writing cdrw, even with just it's own burning proggie. I don't think having 4 drives installed is as much of an issue as the total software package in general ... have you tried reinstalling WinXP? ... it may be faster than screwing around with registries.
 
#3
Here's one solution that worked with a similar problem:

  • Delete the CD-RW AND DVD-drive in the Device Manager.
  • Reboot
  • The startup MAY take a few seconds longer, as Windows XP installs the drivers for the CD-RW and DVD

If you go to My Computer and check your CD-RW drive, it MAY be defined as a CD-ROM station, but as far as I tried it, it doesn't give any problems. Maybe it can give some problems with Windows internal CD-burnprogram, but I don't use that.
 
B

Burpster

Guest
#4
used to have that problem with WinME ....once i updated to XP Pro with forceASPI installed never a problem again
 
F

Flash

Guest
#6
Thank you all for your responses.

Blue
In the past I was always a fan of Easy CD Creator. I switched to Nero a while back. Actually it came with the AOpen drive so I decided to stay with it. So yes I have used DirectCD in the past. Regarding Easy CD I have seen an article that just removing it from Add/Remove programs is not enough, you have to do it manually. But the read problem is not exclusive to burned CDs. When I launch Nero after booting and place a blank in the drive Nero keeps saying "put in mediai", well of course it is there, it can't see it. If I put a data cd in I can't the files, or an error, no media in CD. If I place a data CD in, can be anything, and re-boot, now I can see files, burn, whatever I like to do.

I should have said this before that this was happening with my HP 8100i also, so I don't think it has anything to so with the CD-RW. Like I said I have had the issue for a while. WinXP Pro has been reinstalled many times, you know what mean. ha ha Yes I believe I have the latest firmware for the CD-RW. I'll check again.

Glaanieboy
Thanks, I have tried that, also tried to re-name the drive letters, heard that it may be a problem. I have tried moving my IDEs around, I have left it that the Hard Drives Mas & sla on IDE0, and the CD-RW on IDE 1 master, and the CD/DVD is the slave. I checked the registry last night under key CD Buring and the values are correct for the type of CD drives. But is there a key to define the number of IDE devices? Microsoft K Base was no help.

Burpster
Thanks, yes I have the lastest ASPI files, 4.93 I believe is the latest.

I have no yellow flags in the device manager. The CD/DVD works fine. Maybe a BIOS issue, don't think so, everything worked fine with the same mobo, memory, hardware when I used Win98se.

Thks Jim
 
B

Blue

Guest
#8
oh wot fun then, lol

If you had the problem with another drive as well ... sounds like a hardware setup problem .. not firmware, aspi or whathave you ...

try going into your bios setup and set pio and ide settings to auto ...

I assume both hard drives are on your primary ide connector and your cdrw and dvd are on the secondary, both set to slave?

I'm also assuming here, that you've updated WinXP as there were lots of early problems with CDRW.

if not, try setting them up that way ... if so disconnect your DVD, set your CDRW to master and see if it works properly.

If not gointo device manager and change your ata controller settings ... on the primary channel, they need to be set to dma for your hard drives, but on the secondary, you can try different settings to see if anything makes your CDRW happier.

have fun
 
K

krmanning

Guest
#9
Have you changed your memory timings at all, or are you overclocking? I had a similar problem when I tried to do either of these on my system. As soon as I went back to default settings, then everything worked OK.
 
F

Flash

Guest
#10
Update:

GoNz0
Hi, I did confirm that I have the latest firmware for my CRW4048, ver. 1.07.

Blue
Hi again, yes I confirmed that the BIOS is setup as you have suggested and yes both HDs are on IDE0 and both CD drives are on IDE1> The CD-RW is master and the CD/DVD is slave. I do remember there was an Windows update for CD burning which I have. Later tonight I'll try the CD-RW with the CD/DVD disconnected. For my ATA driver I am using the Intel Accelerator, latest version, as I have the 815E chipset on the mobo. I will try different settings for the CD drives, i.e. DMA, PIO, etc.
As suggested earlier I did remove the CD driver, it is a Microsoft digitally signed driver called Microsoft Windows XP Publisher(?) it put the same one in on reboot and you I can't roll the driver back, it says no driver available. Regardless it looks like I have the recording tab back!? Unfortunaely I didn't have time to check if anything changed. Hopefully tonight.

Krmanning
Hi, I haven't touched my memory settings, but I have been playing with overclocking. I will leave it at the default settings while I trouble shoot this issue.
 

Members online

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,016
Latest member
poordown814