• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

deleting in XP

E

electrolite

Guest
#1
I got these two large movie files off the network I'm on, and now XP won't let me delete them. It says the files are in use, but I've been trying to delete them for about a month, and I'm sure they're not ever in use. Any suggestions?
 
#3
This is a known problem in Windows XP, often broken .avi files show this behavior. There is a fix to this:
Code:
; Windows XP explorer movie fix.
;
; WARNING - Use this file at your own risk.
; 
; Executing this file will remove a registry key which makes explorer load shmedia.dll.
; Simply put, this removes the annoying "permission denied" errors when trying to 
; move/copy/delete AVI files.
;
; To use this fix, right-click on the file and select install. Done.
;
; Information about the registry key from multiple sources. 

[version]
signature="$Windows NT$"

[DefaultInstall]
DelReg = Reduce.Reg

[Reduce.Reg]
HKLM, "SOFTWARE\Classes\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}\InProcServer32"
The file is attached if you want it untampered. Rename it to "avifix.inf" first.
 

Hipster Doofus

Good grief Charlie Brown
#4
Here's the manual fix to get rid of it.

Two Fixes. Try the second first & let us know.

1/ The fix for Windows XP not letting you delete .avi

I've seen this coming up more and more all over the place so I figured I'd stick it here.

Avi files (divx) can be trouble in xp. there is a fix to let xp behave much better so it's possible to move or delete large avi files. The obnoxious bug in XP that causes Explorer to read the entire contents of broken AVI files before allowing any access to them is caused by bad behavior of shmedia.dll.

To correct this misbehavior in Windows XP, remove the following
registry key.

HKEY_LOCAL_MACHINESOFTWAREClas
sesCLSID{87D62D94-71B3-4b9a-9489-5FE6850DC73E}InProcServer32

This will prevent Explorer from loading shmedia.dll in response to file property queries on these files.

Just an extra note, if you do a "search" for this key it will not be found, look for it manually it is very easy to find.


2/ Just open NOTEPAD and then click on "OPEN". Navigate to the file in the little Notepad "explorer" window and right click on the .avi file and delete it. Supposedly that's will do it. by allan

And if you don't want to mess with the registry try this>

Deleting files - Access Denied Error

Close all open applications.
Open a command prompt and navigate to the directory with the offending files.
Then open the Task Manager and click on the Processes tab. select "explorer.exe" under Image Name. Click "End Process".
That will leave you with only the command prompt and the task manager running.
Now at the Command Prompt, its time to delete the file(s). Using the DEL command. Example c:>\movies\DEL movie.avi
Now the files are deleted, go to the task manager and click on the Applications tab. Click the "New Task" button. in the dialog, type explorer.exe and click OK.
 
H

Hematic

Guest
#5
You two guys have saved me so much pain and suffering. Mad props and many beatiful women and gifts are on the way in the mail.
 

Members online

No members online now.

Latest posts

Latest profile posts

Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,016
Latest member
doertilog