Control laptop fan speed

Vanquished

Mr. Bananagrabber
Political User
#1
Hey guys,
I have a dv9000z that came with Vista but I have Windows 7 put on it. And I cant control the fan speed. The CPU temp and a few other temps are in the 60s at idle, so I need to speed up the CPU fan speed. I have an Antec cooling pad, but the computer is still running hot because the fan speed doesn't change at all. If possible I would like to have the CPU speed running at 100% all the time, and power consumption isn't an issue because its usually plugged in anyways.

I've tried SpeedFan but it doesn't recognize the fan; thus I cannot change the speed.
Anybody have any ideas?
I also can't access anything in the bios.

Thanks!
 

LeeJend

OSNN Veteran Addict
#2
If the temp is higher than the design calls for the fan will run max until it cools off. You can't speed the fan up. Laptop bios is pretty much locked out from hacking settings.

Try cleaning the air passages the cooling should improve.

It's also possible the heatsink got knocked loose. That will require disassembly to confirm.

Third possibility is the Win 7 upgrade caused an issue with the power settings. Go into power options and try selecting power saver instead of high performance. You should be able to make your own power plan somewhere between power saving and high performance.
 

Vanquished

Mr. Bananagrabber
Political User
#3
If the temp is higher than the design calls for the fan will run max until it cools off. You can't speed the fan up. Laptop bios is pretty much locked out from hacking settings.

Try cleaning the air passages the cooling should improve.

It's also possible the heatsink got knocked loose. That will require disassembly to confirm.

Third possibility is the Win 7 upgrade caused an issue with the power settings. Go into power options and try selecting power saver instead of high performance. You should be able to make your own power plan somewhere between power saving and high performance.
I know its something caused by windows 7 because it worked before I installed it. I don't want to increase the fan over its capabilities. I just want it to run max all the time, right now it runs on low all the time, regardless of the heat; it doesn't change.
 

American Zombie

Administrator
Staff member
Political User
#4
Type Power in the search box and select power options.

For the power plan you are using click on change plan setting then click on Change advanced power setting.

Look for processor power management and make sure it is set to passive.

What version of SpeedFan did you use?

My board is new (Asus M4A89TD Pro/USB3) and 4.42 will not work with it but does work with the new 4.43 beta as 4.43 uses a new driver.
 

American Zombie

Administrator
Staff member
Political User
#7
Did you try the new beta of Speedfan?

4.43

It uses a new driver.

I am registered there and can get it for you if you do not want to register.
 

LeeJend

OSNN Veteran Addict
#8
Follow what Zombie said but look for "Cooling Method" or "Power Management"

Type Power in the search box and select power options.

For the power plan you are using click on change plan setting then click on Change advanced power setting.

My Toshiba had it hidden under Toshiba POwer Saver Settings - Cooling Method, options were Performance (max cooling) or Battery Optimized (off more)

Also make sure you are not in a "power saver" main setting. Select Performance, there will be more options.

Also, in the advanced power options window was a selection for: "Change Settings That are not Currently Available". Fan control may be disabled.

Note there was not a way to turn the fan on all the time. It still cycles off when not needed.
 

Vanquished

Mr. Bananagrabber
Political User
#10
Follow what Zombie said but look for "Cooling Method" or "Power Management"

Type Power in the search box and select power options.

For the power plan you are using click on change plan setting then click on Change advanced power setting.

My Toshiba had it hidden under Toshiba POwer Saver Settings - Cooling Method, options were Performance (max cooling) or Battery Optimized (off more)

Also make sure you are not in a "power saver" main setting. Select Performance, there will be more options.

Also, in the advanced power options window was a selection for: "Change Settings That are not Currently Available". Fan control may be disabled.

Note there was not a way to turn the fan on all the time. It still cycles off when not needed.
Thanks for the advice AZ and LeeJend,
sorry, I forgot about this problem. I get fed up with things very quickly and after taking the DV9700z apart to see if it was a fan problem (I even oiled it and put arctic silver on it) it still overheats. I may try the speedfan beta (if its still in a beta, lol). Just makes me so mad that this is an extremely common problem with the DV9000 series yet we get no help from HP...
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,971
Messages
673,299
Members
89,016
Latest member
Poseeut