??Clean install->files missing/corrupt hal.dll


OSNN Addict
I have been trying for 2 days to get XPpro installed on a new puter.
Initially It installed ok, but before I could set things up there was a power shortage and the power to the house went off and so did the pc.

On reboot I got the blue screen error message about unmountable disk.

Rather than mess with the thing I just figured I would re-install xp and make sure everything was clean.

The problem now is that after all of the startup files are loaded and the puter reboots for the first time to begin setup I get the message :

the following files are missing or corrupt replace and restart.
<windows> system32/hal.dll

I have several machines, so I have several XP disks. I have tried XP Pro, and I have tried XP home.
Still, I get the same message.
I even took the HD and plugged it into my second puter and copied the hal.dll onto it, then put it back into the initial puter and still I got the same message.

Any suggestions ?? I even tried the repair console (there was a previous post in this forum with a suggestion) but Have not solved the problem yet.

Win XP pro
AthlonXP 1800
Seagate 40g (2 equal partitions)
256k ram

I have reformatted everywhich way, nothing worked.

Have you tried another clean install after this hal problem? and you can't copy the hal.dll from one computer to another because there are slight differences in the hal depending upon the install..so try another clean install and if that doesn't work you might wanna run a full HD check.


OSNN Addict
So far no joy !!

I did a complete scan of the drive and it checks out ok.
I have completely reformatted the drive multiple times and in multiple ways and tried to do a clean install each time but I get that same damn message.

I cannot log on at all so I cannot perform a sysfilecheck (as suggested in another thread)

Changing the mbr does not help.
I have brought reset my bios to absolute min-- no effect.

The thing is IT worked once before. I cannot figure out what changed, nor what to do next???
:mad: :mad:

I copied the hal.dll from another puter--that did not work.
All energy adapti crap is off/disabled.

I EVEN tried moving the HD to my other computer and installing it there, but I get the same message, which makes me think that the problem lies in the HD. I have checked it with every utility I could find-- Seagate sais the drive is fine. Multiple reformats have not worked.
Well, any more ideas would be appreciated, I will keep working on it.



OSNN Addict
YEAH !!!! Problem solved !!

:D :D :D
I am a happy camper again !!
For future reference (hopefully this will help one of you in the future--so if you are searching these forums for help) Here was the solution.
It turns out that SEAGATE has some pos 'driver overlay' which becomes a part of the driver hardware IF you use certain <older> versions of their drive installation hardware.
Well this driver overlay will prevent you from loading Win XP.
As I said above, you get the following error message:
The following files are missing or corrupted. Please replace
<windows root>system32/hal.dll

The way to get rid of this overlay and solve your problem is to use a special program (which should be on the drive installation disk) Do the COMPLETE option (takes about 45 min for a 40G drive)

I booted up with a win98 disk
-start windows using cdrom support
then when you get to the a> put your seagate software disk, switch to your cdrom drive and type DM (for diskManager)
then go to the advanced options and get rid of the crap.

Then reinstall WinXP normally (I chose the option to reformat my drive in ntfs)
Presto you are back in business.
:D I hope this helps one of you out so you don't spend 2 days narrowing down the problem.
I had the same issue if i installed my hard drive in scsi and cdrom on ide. I had to place both of my HD on primary IDE and cdroms on secondary IDE. It was the only solution even from microsoft that sweared bad hardware even after replacing everything but power supply. my board is the Asus A7V266-E. By the way my HD it a 20GB Western Digital 7200RPM and a Maxtor 6.4GB 5400 RPM.